WordPress.org

Support

Support » How-To and Troubleshooting » One server, two WP sites, one upgrade works – one does not. DNS-related.

One server, two WP sites, one upgrade works – one does not. DNS-related.

  • I have a CentOS server with two wordpress sites configured under two separate users.

    One of the sites I was able to login and upgrade to 3.4.2 without any issue. But the other site fails with an error that points to DNS –
    Downloading update from http://wordpress.org/wordpress-3.4.2-partial-1.zip…
    Download failed.: Couldn’t resolve host ‘wordpress.org’
    Installation Failed

    Now, if it were actually DNS – then my other site should not have upgraded. I’ve tried running the upgrade multiple times and same result.

    So… I loaded up tcpdump and did a sniff on the wire. When I execute the upgrade, it is not even attempting to do a DNS query. There is nothing going out.

    My question is, if DNS failed once and the upgrade process failed, is there a file that is flagged or a bit set somewhere that I need to go turn off? Because as of right now, without the upgrader even attempting to query again he will never know whether or not the site is available.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘One server, two WP sites, one upgrade works – one does not. DNS-related.’ is closed to new replies.
Skip to toolbar