Support » Fixing WordPress » One post won’t update–also shows as mobile version on desktop

  • Resolved eileenanddogs

    (@eileenanddogs)


    Hi all,

    I am using WP 4.7.4, with Theme 2010. I have recently been using W3 Total Cache and Cloudflare but disabled them in case they were part of this problem. I have cleared my browser cache (but the problem is the same on other browsers).

    I have one post from March: http://eileenanddogs.com/2017/03/22/falsifiability-dog-training/

    that doesn’t show the normal desktop mode with a header pic, header menu and a right hand sidebar. It shows up in what looks more like mobile mode with a menu in the upper left hand corner. Also, the post won’t update. I made some changes today. The post updates show correctly in Preview mode (and the layout is correct) but in the live version I’m still getting the previous version and the wrong layout. (I’m pretty sure the layout problem predates my edits today. I think I saw it looking wrong and figured it for a temporary glitch.)

    It seems like a cache issue since when I go to the post it loads instantly, faster than normal for my site. But like I said, it shows that way on any browser, with or without a history of showing that post.

    Appreciate any help.

    Eileen Anderson

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes, you’re right, I see the same page here.
    But it looks like you’re still on Cloudflare according to this:
    Nameservers: dee.ns.cloudflare.com, marty.ns.cloudflare.com
    Try switching back to Bluehost’s ones.

    Thread Starter eileenanddogs

    (@eileenanddogs)

    Indeed, I deactivated the plugin but forgot to change the nameservers. Thank you!

    Changed them back to Bluehost’s this morning. Cleared caches, etc., but the post wouldn’t update and I got more and more gateway errors, 504s, etc, such that I finally couldn’t get anywhere in the back-end. Including couldn’t get to plug-ins.

    Went into my cpanel and started renaming plugins that had been recently updated so as to disable them. Found the culprit I think: WP Smush, for optimizing images. Enabled plugins again except for that one and now dashboard accessible again and the post updated. I don’t know why it would have affected that particular post, but it had had a PNG rather than a JPEG in it (unusual for my blog) and maybe that was part of the problem.

    Thank you again for your help, Sinip. I’m hoping Cloudflare wasn’t part of the issue, but if so, I’ll remember next time to change nameservers.

    • This reply was modified 5 years, 5 months ago by eileenanddogs.

    Glad you have it fixed. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘One post won’t update–also shows as mobile version on desktop’ is closed to new replies.