Support » Fixing WordPress » One Post from Last Year Renders Blank Single Post Page

  • Resolved @mercime


    Volunteer Moderator

    This one’s got me stumped. I was preparing to upgrade a site when I found that ONE POST from June 2008 which has 72 comments rendered a blank single page. All other posts are all right in respective single post pages. The affected post was about a small beauty contest which later became a bit controversial when other beauty candidates who lost ranted in said post …

    That post’s title, thumbnail, author link show up in site’s sitemap.xml, in the category, tag, sitemap and archive pages plus in list of top 10 most commented posts. But when I click on the link to the post from above-mentioned pages, the post page is blank. Source view shows from top to bottom: Doctype to <title>, <metas>, and all <link>, scripts rendered from wp_head, are there but then goes straight to </body></html>. There is no closing head </head> nor opening <body> nor content, nor sidebar nor footer info. Changed theme to default theme and a blank page is rendered for the post with basically the same source with no </head> <body> content, sidebar nor footer info. Like I mentioned before, only this post is affected as such.

    Went to Post > Edit and in panel, I can open the post and see the post in the text area, categories are checked and tags are present and comments are shown below the panel. Republished post, cleared cache and cookies, and the post page is still blank screen.

    Doubled-checked database xx_post, xx_comments and xx_postmeta and the post, comments and meta are there. Checked xx_options table to check the usual culprits for hacks but none found.

    Exported XML of the site, and imported to XAMP on USB drive with WP 2.7.1 including theme and all plugins used activated with same settings. The single post page shows the post and comments but the comments_number renders “No Responses” while there are 72 comments below it. All other imported posts show the correct number of comments in respective single post pages.

    Any help would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi there mercime…I see you are quite active on these forums, so I hope you see this post.

    I am having the exact same problem as you describe here. I am so confused as to why it is affecting ONLY ONE post, but the post that is impacted has a large number of comments (nearly 300) as the post is related to a contest we are having. No other posts on our blog have more than about 10-12 comments.

    Another piece of information, this post worked just fine until I upgraded to the newest release of the Kimili Flash embed plugin. However, this post has no flash embedded in it…the only thing that differentiates it is the large number of comments.

    Of course, I could deactivate the plugin, but I run some flash tools that I really need this version for. I would rather fix the underlying problem than deactivate the plugin.

    So confused, please help! Anyone…

    Wanted to provide more information:

    Here is a portion of the source code for the broken post

    [moderated code]

    Alternatively, here related source code of a “good” post. Notice the difference after the script generated by WP-polls…I have no clue why the javascript from Kimili is not showing…

    [moderated code – please put code in a pastebin and report the link back here]



    Volunteer Moderator

    @rylglobal: i see that your post was about a contest too. were there some rants and controversies too? 🙂 The post I referred too is still using 2.7.1 and also using Kimili Flash Embed v2.0.1 for that version. I use Kimili to embed the Picasa album Slideshows in posts. Been using Kimili for that site since WP version 2.3 and upgrades of both WP and Kimili did not affect that post. But now you mentioned it, I will check database again.

    I will be tackling the missing post this weekend or early next week. I decided to make it the last one to upgrade so I can concentrate on retrieving that post!

    I made a mistake in my comment above re

    The single post page shows the post and comments but the comments_number renders “No Responses” while there are 72 comments below it.

    The comment number was not 0, I was just sleepy or cross-eyed then 🙂 At this time, I know that if I export the XML of that site, and make a new and clean install by dumping old database (after making backup) and importing XML in 2.7.1, I can make that specific single post page and comments appear again, then upgrade the site to 2.8.1. But that is the last resort.

    Btw, your code has been deleted by forum mods. For your reference, you can paste code at and post the link here.



    Volunteer Moderator

    Found one missing Post in another installation – same situation where this post had content and comments when going to Page > Edit but renders a blank page in single post view for only that post. Just weird.

    a) export XML of that blog.
    b) Create new XML file and check out the “Breaking WXR into smaller pieces…” section in this codex tutorial to get the “header” and “footer” for the file.
    c) Open up the exported XML and search for that post. Copy that post’s <item> to </item> and paste between the “header” and “footer” of that new XML file and save file.
    d) Double check that the post and comments are complete by comparing with the Edit panel of said post.
    e) Delete the troublesome post from admin.
    f) Import the new XML file made in (b) above and assign to author.
    Viola. Check out the post in single post view and no more blank page.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘One Post from Last Year Renders Blank Single Post Page’ is closed to new replies.