Support » Plugin: Popup Maker - Popup for opt-ins, lead gen, & more » One popup works – the other does not

  • Resolved Pioneer Web Design

    (@swansonphotos)


    Prior to the WP5.6 update and after (I did a full site restore to check, all updates applied now again), one of the 2 popups on the page linked to (the two black buttons) do not work. Both are set up exactly the same except the trigger Extra Selectors.

    I’ve run the troubleshooters also. Nothing so far has helped. They worked before, not sure when the issue started…

    Please review, advise.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Daniel Iser

    (@danieliser)

    @swansonphotos – Your second button has selector with v5video2pop in it, but the popup is set to look for v5video3pop.

    Hope that helps. If your issue is resolved please take a moment to rate and review the plugin or support.

    If you still need help please message us directly at https://wppopupmaker.com/support/.

    Pioneer Web Design

    (@swansonphotos)

    @danieliser

    Actually that is quite unhelpful. Could you please expand on your comment: “your second button has selector with v5video2pop in it, but the popup is set to look for v5video3pop.”

    Again, it was all working just fine for some time (about 2.5 years)…

    Also, please do not mark posts as resolved until the OP has noted it is. I think that’s just a poor way to do things.

    Plugin Author Daniel Iser

    (@danieliser)

    @swansonphotos – To be fair my answer was perfectly clear, the button has a class that does not match what the popup is set up to target. Updating the button or the popup to match the other is the only issue I saw. Both popups function when manually triggered using the console.

    As to why it stopped working, only explanation would honestly be that someone changed it on your end. No reason that only the numeric value in the middle of the class string would change otherwise.

    And finally anytime the problem is clear, the solution was provided and a link to follow up for more prioritized email based support offered, I see no reason to leave the ticket open. I have done this for the bulk of the 30k tickets I’ve answered (between forums and email) and this is actually the first time I’ve heard someone make such a suggestion to leave it open anyways.

    Just for reference, more often than not, users don’t even bother replying that it works, requiring us to chase down whether its solved or not, which we don’t have time to do with such a small team and large user base. Further I tend to provide the correct solution the first time due to the sheer mass of experience gained from the number of tickets processed in the past 5 years.

    If you truly feel your issue is not resolved, as the OP you are free to mark it unresolved yourself as well.

    Pioneer Web Design

    (@swansonphotos)

    I also notice now that the admin toolbar does not work on front end pages, posts. I performed all the troubleshooting steps. For now, I removed the popups and embedded the videos.

    And, I have page, post revision history, nothing was edited.

    And, why did you reply “Updating the button or the popup to match the other is the only issue I saw”?

    The one on the left is this in the editor:

    <button class="v5video1pop">Forging New Paths in Gunshot Detection Video</button>

    On the right is:

    <button class="v5video2pop">Setting AI Free Video</button>

    And this is what is being output:

    left, worked:

    <button class="v5video1pop pum-trigger" style="cursor: pointer;">Forging New Paths in Gunshot Detection Video</button>

    right, did not:

    <button class="v5video2pop">Setting AI Free Video</button>

    There were 2 distinct popups with separate content, the two videos.

    Anywho, thanks…

    Plugin Author Daniel Iser

    (@danieliser)

    @swansonphotos – I believe you are only reading half of my answer it seems, your button does not match your popup settings.

    Your second button has selector with v5video2pop in it, but the popup is set to look for v5video3pop.

    So again if the button is correctly set to v5video2pop as you just noted, then you must update the popup to match it, and last I saw it was not correctly looking for that and instead was looking for v5video3pop.

    Sorry for the confusion, but the answer was provided correctly the first time, rechecked the second time and confirmed again.

    Unfortunately now the popups are not available on the page, or I would have screenshotted the misconfigured popup click trigger setting.

    So if you changed nothing on the page, then the popups settings were at some point changed, no way around that truth unfortunately.

    Both popups worked fine when manually triggered, one worked correctly as it was configured with the same/matching class as the button, the other simply was not set correctly for its click trigger.

    Hope that helps solve the confusion.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.