Support » Theme: Himalayas » One Page Design > Menu Setup > Anchor #home not working

  • Hi there,

    I’m testing your theme and I think it’s really great for an one page website. However, there’s one problem I encounter: the anchor back to the top of the homepage is not working.

    I understand I need to add ‘#home’, using a custom link in the WordPress menu section, but it does not work for me: http://www.name.ext/#home

    Could you please tell what I’m missing here?

    Thanks a lot in advance,
    Plimfec

    [Per the Forum Guidelines we ask you NOT bump posts. We use the ‘no replies’ search on these forums regularly to find people who still need help. By bumping, you remove yourself from that list and make it HARDER for us to find you!]

    • This topic was modified 2 years, 6 months ago by Yui.
    • This topic was modified 2 years, 6 months ago by Yui. Reason: do not bump

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter plimfec

    (@plimfec)

    Figured it out. Seems like a bug to me.

    See Dashboard > Appearance > Customize.

    To force the menu to work properly, you can’t use the header image option the template offers, instead you MUST use the slider. When you choose for a header image, the template just not generates the right code (there’s no destination for the ‘#home’ -> no ‘id=”home”‘ to go to).

    Workaround:

    • 1) Disable your header image
    • 2) Enable the slider instead
    • 3) Choose your homepage for slider 1
    • 4) Don’t use the other sliders
    • 5) Add your header image as a featured image for your homepage now
    • 6) Hide the overlay and text coming with the slider option, using CSS in you child theme

    Use this CSS to hide:

    
    .slider-wrapper .parallax-overlay {
        display: none;
    }
    
    .slider-wrapper .tg-container {
        display: none;
    }
    

    Hi @plimfec,

    We will try to replicate it within our development environment and if found the same issue then, we will be fixing the issue within the theme update. So, thank you for your patience and understanding.

    Thanks and Regards,
    Ankit

    Thread Starter plimfec

    (@plimfec)

    Hi @tgboy,

    No problem, thank you.

    I found two other (minor) bugs I think, perhaps you’re interested. Also present in your own demo https://demo.themegrill.com/himalayas/.

    1)
    When the title in ‘section-title-wrapper’ > ‘main-title’ becomes a bit longer, the template gives a horizontal scrollbar because of the lines generated by ‘main-title:before’ and ‘main-title:after’.

    Example: change the title ‘HIMALAYAS THEME’ into ‘HIMALAYAS THEME HIMALAYAS THEME’ and narrow the screen (or check your mobile device), you’ll see.

    2)
    Switch between the menu items ‘BLOG’ and ‘OUR TEAM’. The background (blue) shifts in a strange way while the page is scrolling.

    Kind regards,
    Plimfec

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘One Page Design > Menu Setup > Anchor #home not working’ is closed to new replies.