Support » Fixing WordPress » One-Click Update works, but Dashboard doesn’t reflect

  • Resolved marrer

    (@marrer)



    I’m having this problem on the InMotion Hosting service, if that has any bearing on the issue.

    I’ve attempted to install WordPress on both a “regular” domain – which is located in the public_html folder – and in a subdomain on my account.

    Let’s start with the regular domain. Assuming my overall account is called MYNAME.com, and the other domain is REGULAR.com, technically the path is http://www.MYNAME.com/REGULAR.com, the world can get to it at http://www.REGULAR.com, and the domain’s folder is in public_html\REGULAR.com.

    I uploaded the 4.9.7 zip file into that folder, extracted the contents and began the install process. Worked like a charm. WordPress detected that 4.9.8 was available during that install and automatically did the update in the process.

    I look in the wp-admin folder and examine the about.php file. It has the time and date that the install just took place, and inside it are references to 4.9.8. When I login and look at the Dashboard, it tells me that I am all up to date.

    Perfect!

    Now I do exactly all of the above to the subdomain. Let’s call it TEST.MYNAME.com, and its folder is located in the main directory (as opposed to the public_html folder). And, as above, the about.php file was updated.

    Yet when I sign in to the Dashboard, it says that I’m at 4.9.7 and that there is the 4.9.8 update available!

    So, I go ahead and click on Update. I quickly see all of the steps that took place (I did a quick screen capture to get them as they disappear so quick). It then says basically “welcome to 4.9.7”, and the changes made in 4.9.8 are listed (supposedly 46 bugs were fixed). And at the top of the screen it is telling me — there is the 4.9.8 update ready and waiting for me!

    By the way, I already went to the Settings -> General section to make sure both the WordPress Address and Site Address fields were correct.

    InMotion’s support desk eventually went to the SSH command line and executed the WP CORE DOWNLOAD ..etc … command to force it. Now in the Dashboard it shows I am up to date with 4.9.8.

    So — why doesn’t the Dashboard One-Click Update work for a subdomain?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    Nope. No caching plugin.

    In fact, I haven’t even tried to install any plugins yet. I wanted to resolve this little anomaly first.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Do you have shell access on the server? If so, cd to the site’s directory and try running wp cache flush

    https://developer.wordpress.org/cli/commands/cache/flush/

    I’ll have to uninstall everything and start from scratch to test this out.

    Of course, the question is – assuming this is the solution to the problem – why would things work correctly on a “regular” domain, but I have to flush the cache on a subdomain?

    After running that wp cache flush command, wiping everything out and restarting, it worked fine. It automatically took me from the 4.9.7 of the zip file to the current 4.9.8.

    I’m going to have to ask the hosting company what kind of defaults might be incorrectly set up on my account regarding caching.

    It might also explain why, on another domain that I am trying to convert from Drupal to WordPress, after wiping out and ensuring that the folder is empty before loading and extracting the WordPress zip file, when the install starts instead of running the WP index.php file, it is attempting to run a ghost version of Drupal’s index.php file!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.