Support » Plugin: ActivityPub » Once installed nothing happened

  • comunicacionabierta

    (@comunicacionabierta)


    Hi!
    I have installed the plugin on my web but nothing really happened. I have look for @danicotillas@comunicacionabierta.net (that should be the profile) on Mastodon an so, and there is none.
    I´m installing now IndieWeb to see if it helps.
    Let me know please if there is something else I have to do,

    Thanks

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Matthias Pfefferle

    (@pfefferle)

    Your webfinger endpoint returns an error 404: https://client.webfinger.net/lookup?resource=danicotillas%40comunicacionabierta.net

    Have you deactivated the plugin? If not, can you try to rebuild the rewrite rules (go to the permalinks settings page and hit “save” without changing something)?

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    The IndieWeb plugin can’t help here. The AP plugin is designed to work without any dependencies.

    comunicacionabierta

    (@comunicacionabierta)

    The plugin is active.
    I have rebuild the rewrite rules but still nothing.
    I don´t know what´s webfinger but as I see on the url it takes /.well-known/ that it´s the folder Let´s Encrypt creates on the server, maybe that´s a problem?

    Also FYI my url it has /blog/ on the links because it comes from an old WPMU installation and I was unable to get rid of that.

    Hope this info helps,

    Thanks!!!

    Nara Ravenhunter

    (@nararavenhunter)

    Had the same problem.

    For me changing the permalinks from “simple” to “day/title” did the trick. Seems like “simple” is clearing all set rewrite rules … :-/

    comunicacionabierta

    (@comunicacionabierta)

    I´ve done it but nothing yet, or maybe I just don´t know how to find @danicotillas@comunicacionabierta.net. Do I have to publish something?
    Try look for me and see if there is success please.

    Thanks!

    Nara Ravenhunter

    (@nararavenhunter)

    Sadly no success … :’-(

    Best I could get was an 404 error and the name of your webserver software: nginx (which I sadly don’t have any experience with).

    But no, you don’t have to publish anything. That part should work without. 🙂

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Oh, you are using NGINX… Can you try the following? https://github.com/pfefferle/wordpress-activitypub/issues/8#issuecomment-450465118

    comunicacionabierta

    (@comunicacionabierta)

    Hi @pfefferle sorry for the dumb question but I don´t know where to put that code on index.php or wherever it has to be.
    Can you explain me with laynman´s instructions?

    Thanks a lot!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    I am not that familar with NGINX… Is there a NGINX config you can edit/extend?

    comunicacionabierta

    (@comunicacionabierta)

    I don´t know because I have never edit/extend the server. I´m using it with a CPanel so I don´t even think I can use the Terminal.
    I think this would be a problem many other people will have, isn´t there a way to upgrade the plugin so there is no need for that? I know this idea is too obvious but in the near future many people will appreciate.
    If you have any idea how I can test it so far, any idea welcome.

    Thanks!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    The complete plugin is build, so that you do not have to configure anything by hand and it works smooth on the classic LAMP stack. The problem is, that the ActivityPub/Mastodon protocol requires/recommends WebFinger and WebFinger needs a specific URL https://comunicacionabierta.net/.well-known/webfinger.

    I use the core functions to build the rewrite rules for that URL: https://github.com/pfefferle/wordpress-activitypub/blob/master/activitypub.php#L84 and on classic LAMP stacks, it works out of the box.

    Perhaps this might help: https://codex.wordpress.org/Nginx

    Jorge Toledo

    (@jorgetoledo)

    Hi everyone. I have the exact same problem as @danicotillas, but on an Apache server.

    @eldelacajita@la-cajita.es doesn’t show up in Mastodon, and WebFinger returns a 404 error. I’ve already tried updating the permalinks, to no avail.

    My wordpress blog is on la-cajita.es/blog/ instead of on the root of the domain. Could that be a problem?

    Is there some kind of propagation I should wait for?
    Should I publish new posts before it starts working?

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Yes, it is because of the subfolder. Are you familiar with .htaccess and mod-rewrite? Have a look at this issue https://github.com/pterotype-project/pterotype/issues/10#issuecomment-440403375

    Jorge Toledo

    (@jorgetoledo)

    OK, I’ll look into it, thanks!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    It is a virtual URL and yes it will be created automatically, see https://la-cajita.es/blog/.well-known/webfinger

    But it has to be at the root of your domain https://la-cajita.es/.well-known/webfinger and this is not possible if WordPress is installed in a subfolder. But in the issue I linked in my previous comment, there is an explanation what you can do to work around this problem.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Once installed nothing happened’ is closed to new replies.