Support » Plugin: Members » On multisite with the private site feature enabled, Super Admins

  • Resolved Joe Banks

    (@joenasagrc)


    Regarding “Fixed: On multisite with the private site feature enabled, block access to logged-in users who do not have access to the specific blog.”

    I might recommend that Super Admins (is_super_admin) be allowed to view a private site, even if they are not listed as a user.

    With this version fix, Super Admins can still administer the site, but cannot view the site from the front.

    Thanks for continued and thorough efforts, as always.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Justin Tadlock

    (@greenshady)

    WordPress God

    Thanks, of course: I should have done that, myself. Thank you!

    Plugin Author Justin Tadlock

    (@greenshady)

    WordPress God

    @joenasagrc – Do you mind giving the latest 2.0 branch a try to make sure this is working right?

    I’ve closed the ticket above as fixed.

    @greenshady

    Glad to help. Verified fix with the following steps:

    1. Logged in to multisite “subfolder” instance as Super Admin
    2. Deactivated current version then activated version 2.0.1-dev on subsite
    3. Visited subsite with “Members” settings “Enable Private Site” and “Disable Feed” already checked
    4. Site is now viewable from “front”; no more message “You do not currently have access to the ‘INSERT NAME’ site. If you believe you should have access, please contact your network administrator…”
    5. Switched to another user, who is neither Super Admin nor user of above site. Message “You do not currently have access to the ‘INSERT NAME’ site” appears as expected.

    Questions or more info, please let me know!

    Plugin Author Justin Tadlock

    (@greenshady)

    WordPress God

    Awesome! Thanks for verifying. That’s all I needed.

    I’m hoping to have a plugin update out tomorrow.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.