Support » Localhost Installs » On Linux server at home open port to get on web want LAN too.

  • I can only log in my WordPress over the Internet. Not on my LAN. It’s LAN name is small2 so I can get to it with http://small2 I have a phpBB fourm on it and I can get to it over the web or LAN. I don’t know why I can’t with WordPress. I like it to work both ways. How would I set that up?

    -Raymond Day

Viewing 6 replies - 1 through 6 (of 6 total)
  • O I guess I should say what it’s running on. A Tonidoplug2.

    root@small2:~# cat /etc/lsb-release
    DISTRIB_DESCRIPTION="Debian Squeeze"

    -Raymond Day

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I like it to work both ways. How would I set that up?

    You really can’t and that’s a good thing. WordPress would probably get confused if it worked both ways. 😉

    All of the URLs generated by your WordPress should be set to your Internet DNS. If you accessed it via the internal name or IP address then you should be 301 redirected to the correct DNS name set in your WordPress site URL and WordPress Address.

    When you access it from your LAN via the external DNS name, you’ll head outside your network, NAT will take over and you’ll make a quick u-turn without actually going out over the Internet.

    This my help a link to a photo I have of the phpsysinfo screen of this Tonidoplug2 I have running in this home with port 80 open so I can use it on the Web. But like I said it be nice to log in on it’s LAN address too.

    Click this link to see neat info on it.

    -Raymond Day

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    That’s some good information there on that page, very useful. 😉

    I’m sure there is a way to hack it but I’d be hesitant to try. If you get the settings wrong WordPress will work from the internal IP address but stop working from the Internet…

    Wow thanks Jan Dembowski. I don’t get why the phpBB message board on it can do it both ways then. I can go to my WWW no-ip address and it’s LAN name. Both work.

    I did make a /etc/wordpress/config-small2.php file and I can go to:

    http://small2/blog/wp-login from there and type in my name and password but it just hangs then.

    I can just go to http://small2/blog and it shows up. I just can’t log in like that.

    I all so have the no-ip address in /etc/wordpress folder.

    -Raymond Day



    Yes, we too run phpBBS3 and WordPress on the same server.
    Both are good, but different.
    We have no difficulty with phpBB3 from outside or LAN, but as many posts attest, there appears to be an issue with WordPress.

    We noticed that phpBB3 navigates by relative addressing from its front page, so as long as the root document can be found, the rest works fine.

    WordPress, in their infinite wisdom, seem to use absolute addressing, so that the web address -appropriate for outside access- defines the front page, and all other pages. This obviously breaks when WordPress is accessed, not by from outside, but on the LAN it would appear something like . So that explains why you can get to the WordPress front page but can’t navigate from it on the LAN.

    How to fix? Some fiddling with local name resolution with /etc/hosts and similar as described above has been reported as successful, but we can’t make it work reliably with all of WordPress, and without causing problems elsewhere.
    Maybe a WordPress guru here knows how to persuade WP into relative addressing, but I don’t know that it is possible.

    This issue has been posted so many times, asking for a solution and closed without a practical answer, it seems worth getting to the bottom of it. WordPress is magnificent, but IMHO this is an irritation that needs a fix..

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘On Linux server at home open port to get on web want LAN too.’ is closed to new replies.