Support » Plugin: WooCommerce » On-hold Status not Sending Emails (Direct Bank Transfer)

  • Resolved ibaslogic

    (@ibaslogic)


    Hello,

    I need help with the on-hold status that is not sending emails to my customers. But, when I manually change the order status to pending payment and then switch back to on-hold, the email will send.

    Mind you, the payment method is the direct bank transfer which automatically set the status to on-hold.

    Please what am I doing wrong. I need the on-hold email sent once the order is made.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there!

    So for some reason, it sounds like the on-hold status email isn’t sending when the order initially switches to on-hold.

    The first thing to check is if the email is actually being sent or not – you can do that by installing the WP Mail Logging plugin, creating a new order, and then checking to see if the on-hold email is shown in the mail log. If not, then we know that the email isn’t being triggered. Here’s the plugin: https://wordpress.org/plugins/wp-mail-logging/

    If the email doesn’t show up in the log, then it’s likely that another plugin or theme on your site is stopping the email from triggering.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.`

    Plugin Support maykato

    (@maykato)

    Hi @ibaslogic

    We’ve not heard back from you in a while, so I’m marking this thread as resolved. Hopefully, you were able to find a solution to your problem! If you have further questions, please feel free to open a new topic.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.