Support » Plugin: WPD Beaver Popups » on button click not working

  • I tested this plugin last week for a pop up to appear on button click action. I had great success.

    Today I cannot get the same to work. I updated 3 plugins this morning including the beaver builder plugin. I was wondering if there is an incompatibility?

    The pop up does not appear. The button instead invokes a # symbol on the page the button is on. I can get the same pop up to appear on a page – I tested it on entrance, on exit, on scroll.

    (my site is not yet live. I am testing this plugin for a site yet to go live.)

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have now placed the button on a saved row (global) in Beaver Builder. I can get the button to work on a test page (using the saved global row) however not on any of my actual webpages such as ‘home’ and ‘about'(using the same global row). Is there anything that precludes a page showing a pop up?

    The button on the test page worked as there was another button (button2) on that page initiating the same pop up. This seemed to allow the button on the saved row (button1) to work.

    So, I removed button2 and button1 would not work.

    Next I replaced all the saved rows on my ‘home’ and ‘about’ page with a custom row with a button and this now works.

    Conclusion: The on button click initiation of a pop up does not work within a shared row?

    Plugin Author smarterdigitalltd

    (@smarterdigitalltd)

    Hi there

    I hope to release an update for this exact issue very soon.

    Was anything figured out on this? I am having the same issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘on button click not working’ is closed to new replies.