Support » Plugin: Backup, Restore and Migrate WordPress Sites With the XCloner Plugin » On activation, db user name used to initialise db password

  • Resolved erwinbr

    (@erwinbr)


    Hello,

    Today, I installed your plugin but ran into some problems when trying it out. (I will report other problems in separate issues.)

    Problem)
    Install and enable plugin, go to its settings and then to Mysql options, change an option, and click on “Save settings”. Result: the admin part of my site became unreachable: db connection error. Digging into the database I found out that in the xcloner options, the db user name was now also stored as db password. Correcting that directly on the db gave me access to the admin part again.

    Testing locally, I could not reproduce the fact that I could not enter into the admin part anymore, but diving into your code, I found this error:

    File: wp-content/plugins/xcloner-backup-and-restore/vendor/watchfulli/xcloner-core/src/Xcloner_Settings.php, meethod settings_init(), line 643 and further:

    
    add_settings_field(
                'xcloner_mysql_password',
                __('Mysql Password', 'xcloner-backup-and-restore'),
                array($this, 'do_form_password_field'),
                'xcloner_mysql_settings_page',
                'xcloner_mysql_settings_group',
                array(
                    'xcloner_mysql_password',
                    __('Wordpress mysql password', 'xcloner-backup-and-restore'),
                    $this->get_db_username(),
                    //'disabled'
                )
            );
    

    Here, you are indeed assigning the user name to the password option.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘On activation, db user name used to initialise db password’ is closed to new replies.