Support » Themes and Templates » ‘older posts’ / page links not working

  • Hi,

    I have only just noticed that my page feature isn’t working on my blog, http://www.jeniwren.com

    I know I need to fix the loops in one of my .php files but I am completely clueless!

    Thanks for your help in advance.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Looks like all links don’t work (try ‘about’ or ‘cv’).

    Did you change something in your .htaccess (or did one of your plugins do that)?

    Peter

    EDIT: forget that about the about/cv page: NoScript blocked linkwithin.com, which obviously prevented me from clicking these links.

    I had listed them for some reason under private! Now they work 🙂

    The problem is the “older posts” link at the bottom of the index page won’t load page 2, it just stays on the most recent posts…

    your category links do the same (or all posts are in all categories)…

    Peter

    Oh, i had them listed as private because I don’t want them listed in text under the header image – as can be seen now. Any ideas to fix that problem as well?!

    You probably have the following code in your header.php:

    <?php wp_list_pages('title_li='); ?>

    which makes the pages display as a list. That part needs to be removed.

    Can you post the contents of your header.php on this site and post the link to it here?

    Peter

    My header code is here, I can’t find the code mentioned above unfortunately – http://wordpress.pastebin.ca/1694498

    I came across a site whic suggests editing my post-template.php in the wp-includes:

    There’s a part here which has an option to exclude specific pages from a list –
    function wp_list_pages($args = ”) {
    $defaults = array(
    ‘depth’ => 0, ‘show_date’ => ”,
    ‘date_format’ => get_option(‘date_format’),
    ‘child_of’ => 0, ‘exclude’ => ”,
    ‘title_li’ => __(‘Pages’), ‘echo’ => 1,
    ‘authors’ => ”, ‘sort_column’ => ‘menu_order, post_title’,
    ‘link_before’ => ”, ‘link_after’ => ”

    The page numbers of about, CV and contact me are 2, 930 and 1373, so do I just put those into the ‘exclude’ section of the code?

    Thanks for your help so far, I appreciate it!

    Oh crap.. now my site’s not loading!

    Any way i can recover the 2.8.4 version of post-template.php??!

    You are a bit trigger happy, ermm, edit happy, right? 😉

    Are you actually editing WP core files?

    Peter

    Problem fixed, but I am sure I need to edit the post-template.php in order to get rid of the irritating list.

    After I nearly broke my website I am going to ask if someone else other than me can help me change the necessary code 🙂

    Well I thought it would be as simple as adding the page numbers to the exclude function (as advised by another forum) but now I am not so sure!

    http://realiventblog.com/2007/04/04/how-to-hide-pages-in-wordpress/ <– the page I got the advice from.

    You never-ever-ever need to edit wp core files to change the looks of your site, all of that is done through your template files.

    Go and see if you find this function in your template files (of your theme): wp_list_pages

    Somewhere in this directory: wp-content/themes/JENIWREN/

    oh: DON’T EDIT ANYTHING YET!!! 🙂

    Peter

    I managed to download a plugin to remove the offending page list finally. So that problem is sorted!

    So now the only issue is the older posts/page dilemma, and I will NOT edit any core files to fix it 🙂

    Can you show us the contents of your .htaccess in your webroot?

    Peter

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘‘older posts’ / page links not working’ is closed to new replies.