Support » Fixing WordPress » “Older Posts” Link on Homepage Broken – URL not including index.php

  • OK, I’ve seen threads about similar problems but none that have quite addressed my issue.

    My blog is very new and I just discovered I had this issue. My main page was too long, so I went into Dashboard-> Settings -> Reading and set my blog to show only 4 posts per page, rather than the default 10.

    When I looked at my site, the four latest posts displayed on the front page, and there was a link to page 2. I clicked it and got a Page Not Found error.

    Here’s the issue, I think:

    The broken link is http://mysite.com/page/2/

    It should be http://mysite.com/index.php/page/2/

    When I manually enter that second URL, it works. But the link that has been created on my page is the wrong one.

    My permalinks have the /index.php/ element included in them. They all work. For some reason, this element is not being included when my blog tries to create additional pages for older entries.

    Thanks so much for any help you can offer.

    Other info

    WP 2.8.4
    Hosted by GoDaddy
    Windows Server
    IIS 7.0
    Wordpress installed to its own directory, not the root

Viewing 1 replies (of 1 total)
  • OK, I have sort of, kind of resolved the issue. However, I’m not entirely happy with my fix. Especially since I have NO IDEA how or why it works.

    Donbert’s comment over in this thread (http://wordpress.org/support/topic/160869/page/2) got me thinking about index.php vs. Index.php. Given that his post concerned broken pagination under IIS, like I was experiencing, I assumed he’d found my problem. Unfortunately, his fix didn’t work for me. I could not find the wp-includes/formatting.php file he mentions in his post.

    Now, as I stated in the original post, the “next page” / “older posts” link would not work with the default URL. If I manually inserted /index.php, however, it would. Earlier, I tried going into Settings -> General and changing the Blog Address to “robzacny.com/index.php” to see if that would work.

    It produced the desired address, robzacny.com/index.php/page/2/ except now that address did not work.

    However, I went into my permalink settings and changed them from:

    /index.php/%year%/%monthnum%/%postname%/

    to

    /Index.php/%year%/%monthnum%/%postname%/

    Capitalizing the “I” in Index made the difference. Now the “older posts” / “next page” link at the bottom of my page works.

    To recap:

    I have set my blog address as http://robzacny.com/index.php

    My permalink structure is: /Index.php/%year%/%monthnum%/%postname%/

    This has gotten my site working. But the fly in the ointment is that my permalinks are now robzacny.com/index.php/Index.php/2009/09/postname/ Not quite as pretty a permalink as I would want.

    I’ll take what I can get, but this doesn’t feel like a “best practice” to me. I don’t know why what I did worked, and I don’t know if there is a more elegant solution available.

    I hope someone can explain some of this to me. Failing that, I hope this is helpful to someone who is experiencing my problem.

Viewing 1 replies (of 1 total)
  • The topic ‘“Older Posts” Link on Homepage Broken – URL not including index.php’ is closed to new replies.