WordPress.org

Forums

Older Posts 404 Error (12 posts)

  1. TannerFresh
    Member
    Posted 1 year ago #

    My website http://tannerfresh.com when clicking older posts I get a 404 error. I do want the permalinks set the way they are for SEO reasons though. HOpefully somebody knows whats going on here.

  2. Ryan Love
    Member
    Posted 1 year ago #

    Is this a new problem?

    How many posts do you currently have on your site?

  3. TannerFresh
    Member
    Posted 1 year ago #

    Ya it is new just because I've recently surpassed my 10 posts that I allow for the homepage.

  4. TannerFresh
    Member
    Posted 1 year ago #

    so I changed it to allow for 11 posts reading somewhere that that helped other users with the problem but it didn't worked for me.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    What happens if you switch to the default permalink structure?

  6. TannerFresh
    Member
    Posted 1 year ago #

    Still gives the same error.

  7. Ryan Love
    Member
    Posted 1 year ago #

    Tanner,

    Are you using any plugins?

    If so temporarily disable them all.

    Then go back to the permalinks settings and save the option "Post Names" again (I know you've already done it, but I want you try it with all plugins deactivated)

    Then see if it works and report back.

  8. TannerFresh
    Member
    Posted 1 year ago #

    Unfortunately that didn't work either, after disabling the plugins i got the same error so I tried default permalinks again and still had no luck.

  9. Ryan Love
    Member
    Posted 1 year ago #

    Hmmm... this is a strange one.

    If you're comfortable giving me your login details I can have a look in the backend of you WordPress and see if I can figure it out.

    If you are comfortable with this, send them to me privately via my contact details - [ link deleted ]

    If not, I don't know what else to suggest, other then contact the theme providers.

  10. TannerFresh
    Member
    Posted 1 year ago #

    Sent you a message in your form!

  11. @Ryan Love Please do not post emails, contact form links or use these forums for contacting people. That is not how support is offered in these forums.

    http://codex.wordpress.org/Forum_Welcome#Helping_Out

  12. Ryan Love
    Member
    Posted 1 year ago #

    @Jan - No problems, I know for the future. Although it was always my intention to come back to this post and let everyone know what the solution was.

    @Tanner - Sorted. Basically you've got 10 posts published, but had set to show 11 posts on the homepage.

    So when anyone clicked to see the second page, there was no second page because you didn't exceed the 11 posts.

    I changed this to 9, which means you do need a second page as you have 10 posts and that stops the 404 error.

    It's worth noting though, for some reason your site is only showing the 5 latest posts on your homepage, then when you click to go to the second page it again shows the first 5 posts.

    I have no clue why this is. All I can suggest is temporarily deactivating ALL your plugins and temporarily change to the default WordPress theme (Twenty thirteen) and see if you can now see more then 5 posts on the homepage, (should be 9).

    If you can, change back to your current theme and see if you can still see more the 5 posts on the homepage.

    If you can, then start re-activating your plugins, 1 by 1 until you find the problem.

    If this doesn't solve the problem, start a new thread in here.

    All the best,
    Ryan

    p.s,

    Don't forget to change your password so I no longer have access to your site!!

Topic Closed

This topic has been closed to new replies.

About this Topic