Support » Fixing WordPress » Older Entries/Archive Pages Not Working when Posts Page is Used.

  • I just realized I have a problem that I never knew existed. In Reading settings I have a assigned a static front page and a posts page. At the bottom of the posts page there’s a link for older posts. Problem is when I click it just goes to the static homepage.

    I don’t believe it’s a plugin issue. Poking around I realized that if I make the posts the front page, instead of the static page everything works fine. But if I assign posts to it’s own page (ie, /blog) the archives as I believe their called don’t work.

    I always thought older entries was one of the most basic features of WP. No where when I assign a static homepage does it suggest it will break the blog archives. Does anyone know why it’s not working and how to correct it.

    BTW the theme is TwentyTen. Here is one of the blogs in question, though it seems to be doing this on any site that I’ve set a static homepage to…

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi


    Forum Moderator

    That’s not the Twenty Ten theme. Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    That is a TwentyTen based theme. I designed the child myself.

    I have tried turning off all plugins. No change.

    I have tried switching to the plain twenty ten as well as Twenty Eleven themes. No Change.

    I have not reset plugins, but I don’t believe it’s plugin related at all. Any site on which I designate the posts as the home page (default) the archive work fine. Any site that has a custom page for the posts and a static homepage, the archives simply redirect to the homepage.

    It’s as if the system has not recognized that the posts are on a designated page and it’s looking for them in the default location.



    Forum Moderator

    That is a TwentyTen based theme

    It may well be but it’s not the original Twenty Ten theme. 🙂

    I don’t believe it’s plugin related at all

    Really? Why? This is part of the most basic troubleshooting.

    Not the original TwentyTen theme. But the function works exactly the same if I set it to original. It’s not a theme based issue, unless the other themes have the same bug.

    It does not respond as a plugin issue. I have tried it on various sites with different plugins and got the same result. Also I deactivated all plugins and nothing changed. Also this seems a fairly common problem. I’ve seen a lot of posts about it yet it and very few solid answers.



    Forum Moderator

    imho, not a wordpress or theme issue – possibly caused by some of the redirects to various urls (?)

    Good catch on the URL’s as this sire does have a redirect. But I don’t think that the issue as I have another site with no redirect at all and it does exactly the same thing.

    I’m almost at the point of thinking this is a WP bug because there seems to be so little in terms of answers. It seems does it on any site that has defines a static homepage and a blog posts page.

    Really, no answers on this? Archives are such basic functionality. That they don’t work with a static front page is a major problem.

    Just to check off the list…

    Not plugin related.
    Not Theme related.
    Not a redirect issue.
    Seems to do it on any site with a static front page.

    Still no simple solutions to what is looking like a bug in WP.

    I have an old version on the K2 theme on a site and it works fine, but with Twenty Ten or Twenty Eleven, the archives links simply don’t work if the site is using a static front page.

    Does anyone know where official bug reports can be submitted.

    I’ve made a little progress. On my other site having the same issue ( I saw that the permalinks ended with the date and not %postname%. Reading up on permalinks it said it should end with %postname%. It would really be a problem to change my permalinks at this stage, but I tried putting %postname% at the end and it fixed the problem, allowing the older posts archive to work.

    I set it back to it’s original structure to try and decide how to proceed without losing all my current URL’s and found the older posts archives continued to work “with my original link stricture of /%postname%/%monthnum%/%year%/”

    It seemed that changing the structure over and back reset something and fixed the problem. But I don’t know how.

    So I went and tried that on my original blog in question ( This perm structure was already “/%year%/%monthnum%/%day%/%postname%/” so I just changed it up then moved it back. Sadly the issue is still present and archives still don’t work.

    Can’t figure why it the problem corrected on the one site but not the other. I’m having a near imposable time getting people to chime in on solution to this problem, but I welcome any ideas.

    And another update. It started working on the other site as well. Apparently that permalink change and switch back took after a few minutes.

    I’m concerned that I can’t pin down the cause, but I seem to have working archives now and still have the same permalink structure so no hassles there. While I’m not convinced it’s solved, it does seem to be working. For now.

    WP support has been disappointing as usual, but at least there’s been some progress.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Older Entries/Archive Pages Not Working when Posts Page is Used.’ is closed to new replies.