WordPress.org

Support

Support » Requests and Feedback » Old Themes and Plugins

Old Themes and Plugins

  • Suggestion: That all themes and plugins that have the been updated in the last month be deleted from their respective repositories. Even if they are compatible with the latest version.

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    @esmi

    Forum Moderator

    What on earth for?

    Addition: Since people, like me, make mistakes, let them edit their comments.

    Correction: That all themes and plugins that have not been updated in the last month be deleted from their respective repositories.

    Esmi, Because all too many themes and plugins are incompatible with the latest version of Word Press, and people need reminding to update.

    esmi

    @esmi

    Forum Moderator

    Again, why on earth remove everything that isn’t one month old? I have 4 themes in the theme repo that haven’t been updated in a few months – because they do not need to be updated. They all work perfectly in WordPress 3.9.1 and in WordPress 4.0 alpha!

    Then there’s the ecommerce plugin that I co-wrote and support that hasn’t been updated recently because – again – it doesn’t need to be updated. It currently has about half a million users. Why should they all be abandoned when the plugin still works perfectly?

    Moderator James Huff

    @macmanx

    And to add to that, I’m using a plugin which hasn’t been updated since 2012, it’s listed as “Compatible up to: 3.3.2,” and yet it’s a very popular plugin, and many hosts even include it in their one-click WordPress installations.

    Why? Because it still works just fine. In the Compatibility section of the plugin listing sidebar, its compatibility results are listed as follows for WordPress 3.9.1: “20 people say it works. 1 person says it’s broken.”

    It’s a simple and yet valuable plugin the developer hasn’t touched for 2 years, and yet it still works and people (including businesses) love it. Why should that be removed?

    This is why we have the compatibility polls in the plugin listings, so users can decide for themselves if they should trust a plugin to be compatible.

    esmi

    @esmi

    Forum Moderator

    Any theme hosted on wordpress.org should remain compatible for around 2 major version updates. So themes being submitted or updated today should still work in wordpress 4.1. That’s well over a year’s worth of compatibility and closer to two years.

    This is why themes & plugins older than 2 years are all clearly flagged up as possibly being incompatible.

    Moderator Jan Dembowski

    @jdembowski

    Volunteer Mod. & Brute Squad

    Addition: Since people, like me, make mistakes, let them edit their comments.

    Also you have up to 60 minutes to edit your posts here.

    http://codex.wordpress.org/Forum_Welcome#Deleting_.2F_Editing_Posts

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Old Themes and Plugins’ is closed to new replies.