Old Site, New Server: Dashboard works but blank homepage (6 posts)

  1. joshri
    Posted 6 years ago #

    I transferred a site from an old server to a new server (bluehost to verio). the new domain name is lpsgroup.com

    i can log in to the dashboard and see all the pages and content, but when i try to preview a page, i get a "page not found" error. if you try to access the homepage, the page is blank. i'm using the k2 theme, but even when i switch to classic or default, i still have the same problem (can log into dashboard, but can't see content on homepage, etc.).

    i followed the educhalk tutorial (http://educhalk.org/blog/?p=50) and tried some of the common fixes given in other threads, but so far i've had no luck. plugins are disabled, cache is cleared, etc.

    any help would be much appreciated. thanks,

  2. Samuel B
    Posted 6 years ago #

    reset permalinks
    admin - settings - permalinks

  3. joshri
    Posted 6 years ago #

    thanks for the suggestion, samboll. unfortunately, the site's still not working.

    one strange thing i did notice while reuploading some files through my ftp server: when i try to delete the wp-contents folder, all the files in each of the folders gets deleted, but the folders cannot be deleted. the only two folders that can be deleted are the classic and default themes. everything else--the k2 theme folder, the plugins folder, etc.--remains intact but empty of all files. i checked the permissions and the wp-contents folder has the same permissions as the default theme folder, so i'm not really sure what the issue is. perhaps this is related to my problem though?

  4. Samuel B
    Posted 6 years ago #

    try deleting .htaccess completely
    does site come back up?

  5. Ben Sutcliffe
    Posted 6 years ago #

    Check with your host that mod_rewrite is available. If it's not, then the only permalink structure you can use is myblog.com?p=postid.

    On some hosts when you delete files the folder won't delete as there are hidden files that are marked read only. This could be a file such as "dwsync.xml", "Thumbs.db" or a file used by your host to monitor it's progress in backing up the server. I've only ever seen this on Plus hosting, but talk to your host and ask about WordPress installations. You might like to try another host, or even wordpress.com if you intend to continue using k2.

  6. joshri
    Posted 6 years ago #

    Thanks for all the suggestions, guys. I still had no luck getting the site to work. I've come up with a temporary solution though.

    Although I am not able to install WordPress in my root directory, I am able to install it in a subdirectory. So I put up the site at lpsgroup.com/new and set up a redirect at lpsgroup.com.

    I'm not a huge fan of this solution at all and would like to install the site properly at lpsgroup.com, but I'm still having trouble doing so. I've followed the instructions on wp codex for how to change the site URL, but when I do I merely get a blank homepage once again.

    If I try to install a fresh version of wordpress (new database tables, new folders) I get to step 2 of the install process (after running wp-admin/install.php) and get a blank page.

    It just seems like Verio does not want me to install WordPress in the root directory at all, even though it has no problem letting me install it in a subdirectory ("new"). Any ideas or suggestions?

    Thanks again,

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.