Support » Plugin: BP MPO Activity Filter » Old PHP versions

  • ucsdmatthew

    (@ucsdmatthew)


    The latest version includes the new [] array syntax, which breaks compatibility of old versions of PHP such as php5.3, which though no longer supported by its original developer is still supported and maintained with security patches by long-term-support releases of RedHat.

    Would it be possible to change that array declaration from [] to Array()? I made that change myself to quickly get running, though I know it will get wiped out with the next release.

    If not, I would appreciate if you would officially document your minimum PHP version (per https://make.wordpress.org/plugins/2017/08/29/minimum-php-version-requirement/ ), which would provide documentation for the need to allocate the time to upgrade to a current release of PHP.

    Observed error:

    PHP Parse error: syntax error, unexpected ‘[‘ in /unixapps/knitprod/wordpress/wp-content/plugins/bp-mpo-activity-filter/bp-mpo-activity-filter-bp-functions.php on line 24

    Thank you!
    -Matthew

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Boone Gorges

    (@boonebgorges)

    Hi Matthew – Thanks for the thorough request, and apologies for the unexpected breakage. The thought of the array syntax hadn’t occurred to me at the time of release.

    In this case, PHP 5.2 support is trivial to implement, so I’ve gone ahead and done it. Version 1.2.2 of the plugin should be available in the plugin repo momentarily.

    However, I’ve also added a Requires PHP: 5.3 header to this plugin, as a warning that PHP 5.2 support will not be guaranteed going forward. This is in keeping with the policy of BuddyPress itself since version 2.8. https://codex.buddypress.org/getting-started/buddypress-2-8-will-require-php-5-3/

    Again, thanks for your patience.

    Thread Starter ucsdmatthew

    (@ucsdmatthew)

    Awesome, thanks for making that change! I probably have a half dozen commits on the plugin I wrote for our site with exactly that same change, after deploying from my workstation to the stageing environment 🙂

    It does sound like our not-too-distant plan is to move this to hosting that supports a modern PHP, so hopefully we won’t be crying when 5.3 does get dropped.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Old PHP versions’ is closed to new replies.