• atutrabajocoach

    (@atutrabajocoach)


    Dear. Good morning.

    This is only for “information” purposes and/or in case someone can provide “solutions” and/or in case someone has the time (or desire) to pass it on to WordPress so that it can correct it in future updates. I have installed WordPress for (approx)+5 years and I created a site (atutrabajo.org) whose “distinctive” feature is that it is made with the “Hello Elementor” template.

    But, I ONLY used Elementor for the Home Page. ALL other pages (33) and entries (8) were made with the Classic Editor. 1) About the “old” error For some time now (I DON’T remember which version of WordPress), every time

    I’m working in the (classic) editor of my site, the following happens: When I write any sentence.

    For example… …”This is an (example) sentence”… If (with the cursor) I “stop” on the 1st. letter of the phrase (the E in Esta) and, I want to “slide” the cursor with the right arrow on the keyboard, to correct or add (for example) letters and/or words to the text.

    For example, to make it look like this…

    …”This is one of the example sentences”…

    The cursor “jumps” up and positions itself ANYWHERE.

    Ergo, I have to go with the mouse, click in front of the phrase/s I want to correct, etc.

    In other words… Somehow, the classic editor does NOT allow the cursor to slide through the text.

    Which makes writing/correcting text with this platform VERY cumbersome.

    2) Regarding the “new” bug (In version 6.4.2) This one is “simple”.

    When I installed this latest version NO changes made in the classic editor were saved.

    However, guess what? Exact. On the main page (made with Elementor) Yes.

    Ergo. Another mistake (one more) of those who DID NOT take/have/will take into consideration, the fact that – there are still MANY of us who continue to use the Classic Editor.

    Anyway. I will continue with the previous version of WordPress (6.4.1), until someone can provide a solution or a (new) update arrives that corrects this.

    See you.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • threadi

    (@threadi)

    I’ve been using the Classic Editor a lot recently and never had a problem like this. I suspect the behaviour (of both problems you describe) is related to the plugins you are using. Deactivate them as a test to rule them out as the cause. If it no longer happens without all plugins, activate them one by one until you have found the culprit.

    Thread Starter atutrabajocoach

    (@atutrabajocoach)

    Hello threadi. Thanks for responding and I appreciate the advice. But not.

    And I’ll explain why:
    I started the redesign of my site, +2 years ago. To do this, what I did was;
    1) I created a subdomain (stage9)
    2) In it I created a test site (stage9.atutrabajo) and there, I copied my “old” site.
    Finally…
    3) I removed (almost) all the plugins I had and added others.
    Ergo. I ALWAYS had the same (19) plugins.

    As I said…

    The stage worked PERFECT (while I was redesigning my ENTIRE site) and, with the 19 aforementioned plugins.

    But one day, with a couple of versions of WordPress that I no longer remember which, it started to have various problems:

    a) First, it DELETED ALL the custom codes I had for line breaks.
    And after denying a lot and NOT getting answers from the community (or from WordPress), I ended up solving it myself with a code in my function.php that makes each short code that I add for the line break in question, be “respected” by any browser.
    But then, I had to replace one by one on my ENTIRE site, the custom CSS code I had with the shortcode in question.

    b) Then came what I mentioned (the thing about NOT letting the cursor move through the text).

    But I did NOT pay attention to it because I did NOT want to renege again (Neither with the community nor with WordPress).

    Ergo. What I did was simply go with the mouse to the part of the text I wanted to correct, correct it, save it, and that’s it.

    And finally (before version 6.4.2 that caused this)…
    c) After I don’t remember which version, a new “error” (EXCLUSIVE for classic editors:(.
    And the thing is, when I edited, if the text was very long (and mine are, heh), the classic editor panel (the one where the bold, italics, center, etc. are), did NOT move with the text.
    Ergo, if I wanted to do any of that (bold, italic, etc.), I had to point to the text, go through ALL the content, until I found the editor, click on what I wanted (bold, italic, etc.) and continue working.

    Obviously I made the complaint because this was VERY cumbersome, I stayed on the previous version of WordPress and waited until, in later versions, the problem was solved.

    AND ALWAYS with my (19) plugins.

    And now this (version 6.4.2).

    Conclusion:
    The problem is NOT ANY of my 19 plugins.

    The problem is that, every time WordPress makes a new update, it does NOT take into account those of us who (still) use the classic editor.

    Ergo, sometimes it “hits it” and there are NO problems. And sometimes NOT (as is – again – the case with version 6.4.2).

    I hope it is understood.

    One way or another, thank you for your time.

    Greetings.

    Unfortunately, your conclusion is wrong. As I said, the text input works absolutely fine with a freshly installed WordPress without any plugins and with a standard theme in the Classic Editor. One of your plugins or even your theme could be the cause if they are not compatible with the current WordPress. The only correct way to find out is to use a process of elimination to find the cause. If you continue to have the problem without any plugins and with a standard theme, then – and only then – should you take a closer look at WordPress itself (which I currently doubt, as it works for me in several installations without any problems).

    Hence my advice again:
    Update all plugins as well as the theme first. Will it work then?
    Deactivate all plugins. Does it work then?
    Change the theme to a standard theme (like TwentyTwentyFour). Does it work then?

    Thread Starter atutrabajocoach

    (@atutrabajocoach)

    Hello @threadi

    Thank you (again) for your intervention.

    But what may not have been clear is that I ALREADY have my installation online.

    I mean, if I do what you say, my readers will see ANYTHING in their browsers.

    Same and, for now, I am NOT editing because, with what I just uploaded (3 pillar pages of between 30 and 60 thousand words + 8 entries of between 3 and 15 thousand words), they have more than enough, heh.

    In the meantime, I will continue with my version 6.4.1 and wait for the problem(s) to be resolved in successive versions.

    Finally…

    If it were as you say, how is it that, until now, I was able to edit, without problems, such a quantity of content, with the same number of plugins and the same theme, FROM THE BEGINNING?

    Anyway.

    One way or another, thank you.

    Greetings.

    You can also carry out the tests described in a live system. If your website does not have 100 visitors per minute, it is unlikely that anyone will notice. The tests I have described are actually completed within a few minutes.

    If you are still unsure about this, you can also create a project copy. Plugins such as https://wordpress.org/plugins/wp-staging/ can help with this. You can then carry out the tests in the copy.

    Thread Starter atutrabajocoach

    (@atutrabajocoach)

    Now I have to go out.

    I’ll try it another time.

    I’ll tell you later.

    See you.

    Thread Starter atutrabajocoach

    (@atutrabajocoach)

    Hello threadi. In the end you were right, heh.
    And I didn’t even have to do the test(s) we talked about.
    I simply made a backup, updated WordPress to 6.4.2, tried saving again and…
    Soooo! EVERYTHING kept as always. Anyway.
    And not only that. Not even what I told you about the cursor was like that (I’ll explain it now).

    I started to investigate a little and (I think) I “discovered” what had happened…

    I’ll explain to you (Just for informational purposes and, in case someone went/goes/will go through the same thing:).

    a) Regarding the issue of saving changes
    LONG after I had updated WP to 6.4.2 and, when I finished reuploading the site, I realized that something needed to be fixed.
    The 1st The page I chose to change was the largest (Interview with +66 thousand words).
    Since it was taking a LONG time to save the changes, I interrupted it (I refreshed the page).
    There I got an error (I don’t remember which one). And, since what I had to correct was a link of the buttons that I created with html, I thought that it would be better to correct it with the “Code Editor”.
    I did the latter but… That’s where the problems started! () () I got an error (I don’t remember which one), related to the fact that I was correcting and saving from the HTML Editor and not from the text editor (which is what I finally did).

    From then on, he will edit the page or enter whatever, NOTHING was saved.

    Ergo. What I did was go look in my backups (I have a daily one) and I went back, I tried, I went back, until I reached the one I had made before updating to WordPress 6.4.2.

    There I tried and, since the saving thing was OK (not the “cursor” thing), I assumed that was it.

    I left it at 6.4.1, made all the remaining fixes, on all pages/posts and, having “assumed” it was this, opened this ticket, heh.

    Conclusion:
    The “error” had actually apparently occurred due to having interrupted the saving process prematurely.
    Ergo. When I went back (backup through), all I had done was go BEFORE even making that correction whose saving I abruptly interrupted).
    Nothing more (No less), heh.

    b) Regarding the cursor
    EXACTLY the same thing happens, heh. Due to the size of my pages (and some entries), when I want to correct a text, the cursor has a “hard time” moving.
    Ergo, it “seems” to “jump”, but in reality, it “settles” and then yes, it lets me scroll through the text (Slowly, but it lets me, heh:)

    Conclusion 2: IT NEVER stopped working WELL. It’s just that, I don’t have that much patience anymore, heh.

    In summary. WordPress 6.4.2 is NOT the problem. The problem is me (At this age I no longer want to wait so long for things ¯_(ツ)_/¯)

    So, for finishing. The only thing I have pending is the following.
    When I go to my Administration Panel / Appearance / File and Theme Editor / Theme Functions (function.php) and enter ANY code, when I click save, I get the following error message…
    Scrape key check failed. Please try again.
    So, what I do is go out and then the famous sign appears…
    Do you want to leave the website?
    Changes may not be saved
    Ergo, when exiting, these changes are NOT saved.
    And how do I do it? Simple.
    I go to my cPanel/File Manager/public_html/wp-content/themes/mitheme/michildtheme/function.php
    And there I load whatever code, save the changes, and that’s it.
    But it would be nice to be able to do it from my Administration Panel like everyone else, right?

    Any ideas how to correct this?

    For now that’s all.

    Again, thanks (And sorry for the “can” heh:)

    Greetings.

    This error can also be caused by a plugin or theme you are using. The advice for investigation is the same as above.

    Thread Starter atutrabajocoach

    (@atutrabajocoach)

    Well. So, I’ll try the tests later and I’ll tell you. For now that’s all. Thank you so much. Greetings.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.