WordPress.org

Support

Support » Plugins and Hacks » Easy Modal » Old Modals Not Opening After Buying Premium Version

Old Modals Not Opening After Buying Premium Version

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author danieliser

    @danieliser

    Hey nzguyyy,

    Im getting an error in the console when i click the button. The modal begins to open because the overlay is being shown.

    TypeError: f.curCSS is not a function

    After a google search i found this http://wordpress.org/support/topic/typeerror-ccurcss-is-not-a-function?replies=4

    If you upgraded your jquery version you may need to also update your jquery ui.

    The modal is opening but uses background color animations and we include a color animation plugin but since your theme is loading jquery-ui after our animation js file its bg-color animation overrides our functions, because of this your options are to either upgrade jquery-ui or remove it if your not using it.

    Hope this helps.

    Hi Danieliser

    Thanks for the help. Excuse my naivety, but I have no idea how to update or delete my jquery ui.

    Please can you help?

    I have updated WordPress as well as installed the jQuerey Updater plug-in but am getting the same error.

    Plugin Author danieliser

    @danieliser

    I will have to look through the files being loaded to be sure but I would say most likely one of the plugins your using isn’t using the built in versions of jquery UI

    Have you tried disabling a few plugins at a time to see of it gets fixed?

    I have just tried deactivating them all but the problem still remains

    Any idea what else could be going on? I am missing out on quite a few bookings whilst the plugin doesn’t work. :-/

    Plugin Author danieliser

    @danieliser

    I see that something called AgodaSearchBox is calling jquery-ui from within its own js. Do you have a plugin that may be connected to this? Can you try disabling it if so and seeing if that fixes the issue? If so i will have to do some work to figure out a way to avoid it in the future.

    Awesome, thanks. That fixed the issue.

    So until you find a fix the two won’t be able to work simultaneously on my site?

    Plugin Author danieliser

    @danieliser

    Ok so essentially jQuerys most recent versions did away with a function that is heavily used in jQuery UI. Jquery UI fixed this by adding that function to the jQuery-UI library.

    So since we cant fix the version being loaded we need to downgrade your sites jQuery to match it. I believe the latest version in the 1.7 series should be correct.

    The other option would be to simply modify the easy-modal.min.js file and comment out the animation of the overlay bg color.

    Thanks

    How do I downgrade my jQuery? Or would you suggest modifying the easy-modal.min.js file?

    Plugin Author danieliser

    @danieliser

    My opinion on that depends on your specific needs. If your like me constantly have to keep everything up to date, always clicking the update button then you would want to downgrade jQuery, If you get a site working the way you want and just leave it never updating unless neccessary then modifying easy-modal.min.js would be the fastest easiest solution.

    But any time you update easy modal you may end up having to make the change each time.

    Plugin Author danieliser

    @danieliser

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Old Modals Not Opening After Buying Premium Version’ is closed to new replies.
Skip to toolbar