Support » Fixing WordPress » Old homepage displaying in incognito windows only

  • Resolved chloerivet

    (@chloerivet)


    Hi!

    I hope I am in the right place for some support on this issue. My hosting hasn’t been very helpful.

    I have noticed that when I look at my website equestriannextdoor.com with an incognito window from Chrome (desktop Version 89.0.4389.72 (Official Build) (64-bit) and Chrome book) and Edge Version 88.0.705.81 (Official build) (64-bit) (with clear cache after each session), it redirects to https://equestriannextdoor.com/?doing_wp_cron=1611926655.9241681098937988281250.
    When I navigate to another page on my website, the new pages load. If I return to the home page and refresh, the new page shows.

    I expect to see my updated homepage when I access this URL from all types of browsers, incognito or not.

    My husband has also experienced the same issue from his work computer. It does not do this on my mobile or my hubby’s.

    Things I have tried to resolve the issue:
    Updated all plugins and themes.
    Clearing all caches.
    Contacting my hosting.
    Turning off all plugins.
    Using a different theme.
    Resetting permalinks.
    Scanned for malware using a plugin, hosting had run one, I have also used a site scan.
    Scanned WordPress Core to errors.
    Disabled all cron jobs.
    Looked at the cron jobs running using a plugin.
    Turning off Cloudfare.
    Checked my wp-config.
    Checked my htaccess.

    And the cherry on top. I have been fiddling so much with my website that my hosting has suspended my account…. but the incognito home page is still working!

    Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • When I open your site I get:
    This Account has been suspended.
    Contact your hosting provider for more information.

    Thread Starter chloerivet

    (@chloerivet)

    Hi,

    Yes, I am encountering an unexpected and unrelated issue at the moment.
    Except that when I use equestriannextdoor.com on an incognito window’ I still see my old home page.

    It was for sure caused by some cache, usually caching plugins disable the cache when you’re logged in, that’s why you see the uncached page in non-incognito

    Thread Starter chloerivet

    (@chloerivet)

    I thought incognito windows started with a clean cache? Wouldn’t that mean that it should display the most recent version?

    In my case, the incognito window shows the old version that dates back to more than a month.

    The cache is not on Windows, it’s on your server, the pages are cached if you have caching plugins
    but more than a month is very strange… anyway it’s hard to debug now

    • This reply was modified 2 years, 11 months ago by f_monts.
    Thread Starter chloerivet

    (@chloerivet)

    Thank you!

    I contacted my hosting several times and was told different things, but never a hosting issue.

    It is resolved now after upgrading my hosting.

    Thank you for taking the time for exchanging with me. Have a great day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Old homepage displaying in incognito windows only’ is closed to new replies.