Support » Theme: Hueman » Old database option for favicon link breaks my HTTPS

  • Resolved solvap

    (@solvap)


    Hello,

    I have been using a minimal Hueman child theme where I’ve made some CSS edits for years.

    I recently switched over to HTTPS for my blog, and I notice I get a “mixed content” warning in chrome, telling me my website

    has loaded over HTTPS, but requested an insecure favicon

    1. In the site’s source code I see <link rel="shortcut icon" href="http://www.mydomain.com/wp-content/uploads/path/myicon.png" /> inside the HEAD tags.
    2. I tried to change the favicon via the customizer, and noticed none was loaded there. And even if I do input a favicon there, the step 1 link rel still remains.
    3. I searched inside WP header and all php files, nothing hard coded there either. In fact I didn’t ever edit any theme file.
    4. I searched inside the database with phpmyadmin for “myicon” and found the HTTP (insecure) link referenced inside table wp_options in the option_value of option_name hu_theme_options and option_tree.
    5. I tried to change the link there to start with https:// but it broke my design, and pretty much nothing loaded right, so I reverted the changes and I’m still stuck with mixed content.

    I am guessing since the favicon was passed as an option in the database via an older version of Hueman’s options, the current version should be able to replace it. Alas, that wasn’t the case for me.

    I would appreciate any suggestion you could make!

Viewing 2 replies - 1 through 2 (of 2 total)
  • solvap

    (@solvap)

    Could someone please help me with this or make a suggestion?

    Obviously options hu_theme_options and option_tree in the wp_options table were populated by a much older version of Hueman’s settings, and they can no longer be accessed/changed via modern Hueman’s customizer. So I am stuck with an old, http (insecure) favicon meta link.

    Should I delete these options by deleting their option_name entries in the database (hu_theme_options, option_tree), and start over customizing my theme? Or would that break my WordPress database?

    I am hoping the developers would be familiar with these database entries? Thank you for any help/insight you could send my way!

    Well, nobody replied, so what I did and it worked in my case was:

    1) Uninstalled both Hueman and the Hueman child theme.
    2) Used PHPmyAdmin to delete hu_theme_options and option_tree from the database.
    3) Re-installed both Hueman and the Hueman child theme, then used customizer to input the new favicon.

    It worked in my case! 🙂 However I do not recommend this if you are facing a similar issue unless you are certain you can properly backup and restore your database in case something goes wrong. Good luck!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Old database option for favicon link breaks my HTTPS’ is closed to new replies.