Support » Plugin: BackWPup - WordPress Backup Plugin » Old backups not deleted

  • Resolved Henk Barreveld

    (@henk-barreveld)


    I have been using BackWPup for more than a year: one backup job, both files and database, automatic backups twice per week, stored locally (a folder outside public_html) and on Dropbox. Settings are made to keep maximum 6 backups on both.

    Since begin 2018 old backups are no longer automatically deleted. Old logfiles show messages like “One backup file deleted”, “One file deleted from Dropbox” and “One old log deleted”, but the first two messages no longer appear and the backups are not deleted either. There are no error messages in the logfiles. I made sure not to change (or just re-save) the backup job.

    In particular for the Dropbox backup this is inconvenient because of the limited storage space.

    What can I do?

    Thank you in advance for your help.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    @henk-barreveld
    please give me your debug information ( BackWPUp-> Settings -> Infomation tab -> press Get Debug Info )
    Also, could you please try to create a whole new job and set it to Dropbox too see if the old backups got deleted?

    @duongcuong96

    Debug information from BackWPUp > Settings > Infomation > Get Debug Info below.

    Created and ran new job that backs up to the same folder on Dropbox: new file created, no old file deleted.

    Thank you for your help; hope this is useful

    ————————————————————-

    WordPress version: 4.9.5
    BackWPup version: 3.4.4
    PHP version: 7.1.16 (64bit)
    MySQL version: 5.6.36-82.1-log
    cURL version: 7.53.0
    cURL SSL version: OpenSSL/1.0.2k
    WP-Cron url: https://bcstar.nl/wp-cron.php
    Server self connect: Response Test O.K.
    Document root: /home/bcstar31/public_html
    Temp folder: /home/bcstar31/public_html/wp-content/uploads/backwpup-566b45-temp/
    Log folder: /home/bcstar31/backups/logs/
    Server: Apache
    Operating System: Linux
    PHP SAPI: cgi-fcgi
    Current PHP user: bcstar31
    Maximum execution time: 300 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 13:56
    Blog Time: 15:56
    Blog Timezone: Europe/Amsterdam
    Blog Time offset: 2 hours
    Blog language: en-US
    MySQL Client encoding: utf8
    PHP Memory limit: 768M
    WP memory limit: 40M
    WP maximum memory limit: 768M
    Memory in use: 8.00 MB
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dba, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, json, ldap, libxml, mbstring, mcrypt, memcached, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, readline, session, shmop, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    Plugin Support duongcuong96

    (@duongcuong96)

    @henk-barreveld
    go to BackWPUp -> Settings -> Logs -> Logging Level -> Debug(not translated ). Re-run the job again and give me latest debug log file.
    You can get latest backup log file at BackWpUp -> Logs.
    Also, please give me all screenshots of your job config.

    @duongcuong96

    Sorry, I have been away. I now have a zip-file with 11 screenshots of the job configuration and a debug log file. Please let me know how to send it to you.

    Plugin Support duongcuong96

    (@duongcuong96)

    @henk-barreveld)
    You can using online image storage service and post the image links in here 🙂

    Yes, of course, but the screenshots and logfile contain some security-sensitive information that I do not want to make available through a public media like the WordPress support pages.

    The archive name appears to be the issue.

    backwpup_%hash%_[whatever] is the old style name and SHOULD auto-delete.

    backwpup_[whatever]_%hash%_[whatever] will not auto-delete because the hash has to be the second token when the name begins with “backwpup” (as I understand it).

    [whatever]_%hash%_[whatever] does not seem to auto-delete, but should (as I understand it).

    [whatever]_%hash% auto-deletes.

    Plugin Support duongcuong96

    (@duongcuong96)

    @henk-barreveld
    you can hide/remove your server name and server path before upload it in here 🙂
    also, as @trsmith3 said, what is your archive file name?

    • This reply was modified 2 years, 2 months ago by duongcuong96.

    Hello,

    Ok, this has been SOLVED, thanks to @trsmith3.

    I indeed used an archive name of the format backwpup_[whatever]_%hash%, to be precise: backwpup_%Y-%m-%d_%H-%i-%s_%hash%. I used this so that sorting the file names in alphabetical order implied sorting them in time.

    I changed this into: backwpup_%hash%_%Y-%m-%d_%H-%i-%s. For testing I also changed the number of backups to be kept to 2 (both local folder and Dropbox) and ran the backup job four times. I found that now only the two most recent copies are kept; earlier backups (with the same file name format) are automatically deleted.

    So this is indeed a problem with file names – undocumented, I think; I only see that ‘%hash% must be included anywhere in the archive name’.

    Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Old backups not deleted’ is closed to new replies.