Support » Plugin: BackUpWordPress » Old backups are not deleted

  • I had to remove this plugin. My home directory was about 50 GB:

    So the backup grows and it does not delete old backups.

    I have asked my webhost to create backups. Don’t use a plugin for backups.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Tom Willmot


    Hey Reginald,

    Really sorry to hear you ran into an issue with backups not being deleted, that definitely shouldn’t have been happening!

    I’d love to find and fix the problem, did you ever contact our support about the issue? Would you be up for re-installing the plugin and giving me access so I can find out why it was doing that? Totally understand if not obviously but as I said, I’d love to find and fix the issue.

    Apologies again for the trouble it caused!

    Hi Tom,

    I did not contact your support because I figured this was standard behavior. Sorry about that.

    I can install it on another website to see how it works and I will keep you posted.

    Best regards,


    Plugin Author Tom Willmot


    It should only store the previous 3 full backups and the previous 7 database backups by default although it is possible to change that yourself (I assume you didn’t do that?).

    It could be that something to do with your setup meant the plugin wasn’t deleting them as it should, if that’s the case then I’d love to understand what edge case the plugin was failing on and fix it. Even if you don’t end up using the plugin yourself, fixing it will surely help others!

    I have installed it on another website:

    Backup my database (979 kB) daily at 23:00, store the last 7 backups in /wp-content/backupwordpress-89d278ef20-backups.

    I did not change any of the default settings (not on the previous site, not on the new site).

    I will keep you posted.

    Plugin Author Tom Willmot


    Great, really appreciate you helping out!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Old backups are not deleted’ is closed to new replies.