Support » Plugin: All-in-One Event Calendar » OK, Permalinks are the problem. Now what?

  • Resolved ADeweyan

    (@adeweyan)


    Hi.

    Love your calendar. Far and away the best one I’ve seen for WordPress.

    However, we’ve run into the problem with the “Something went wrong while fetching events” error (request status 200, error; SyntaxError: Unexpected token ‘<‘). The calendar used to work fine — this only started recently (I know, that sounds like a plugin conflict).

    I tried re-saving settings, turning off the firewall, disabling plugins, etc., and eventually solved the problem when I deactivated Permalinks.

    However, we have to use meaningful Permalinks, so I’m not sure what to do next. Any suggestions would be appreciated.

    Note that we are not using Apache, but are on the Nginx webserver.

    https://wordpress.org/plugins/all-in-one-event-calendar/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benjamin

    (@bsokic)

    Hi,

    1. Make sure that your Calendar page is set to the right page in the settings.
    2. No need to use shortcode on a page set as the default in the plugin settings.
    3. Try turning on/off “Strict compatibility content filtering” in Events -> Settings –> Viewing Events.
    4. Try turning on/off “Use frontend rendering” in Events -> Settings –> Advanced.

    Do you use “iThemes Security” plugin?

    ADeweyan

    (@adeweyan)

    Excellent. Thanks. We originally had calendars on several pages, but now it’s just one page. I set that to the “Calendar Page” in the settings, and that seems to have solved the problem.

    Just FYI, no, we don’t use the iThemes Security plugin.

    Thanks again.

    Plugin Author Benjamin

    (@bsokic)

    No problem, I am glad your problem is solved 🙂

    Take care,
    Ben

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘OK, Permalinks are the problem. Now what?’ is closed to new replies.