Support » Plugin: Cactus Masonry Classic » Good

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author cactus.cloud

    (@bortpress)

    Hi,

    Cactus masonry only uses the default built in WordPress API calls – the same calls which your theme and any other post-querying plugin would almost certainly use. In addition, the plugin never directly queries the database without going through the standard API, nor does it at any point write or modify any data in the database or the server. Cactus Masonry CANNOT mess up your images.

    With 1000s of active installs, I have never seen any error like this. It is most likely an issue with your wordpress install, a virus, another plugin, or an issue with your server. It is extremely unlikely, if possible at all, that the plugin has caused your issue. But I doubt my saying this would change your mind as you have already decided the cause.

    Does the issue only happen in chrome? A quick web search shows that the ERR_INCOMPLETE_CHUNKED_ENCODING affects chrome under a variety of circumstances.

    Knowing nothing of your wordpress install, what your displaying, your server, and the load on that server, there is no way I can provide any advice further than that.

    Thanks for the response! I realize now that the images were “messed up” when I uploaded them – sorry for blaming it on your awesome plugin.

    I have no idea what could’ve caused it: maybe it could have to do with my free server from x10hosting, but I don’t know. I apologize for my assumption in my review – I saw that uninstalling the plugin fixed the error and thought that must be it – but now I realize otherwise.

    I’m not sure if it only happens in Chrome as i was very focused on fixing the error.

    My wordpress installation is 4.4.2, I am displaying a featured image gallery from a YouTube importer, and I have no ideas about the server.

    Trying again in a few minutes 😀 – its a unique plugin and it really is amazing.

    Plugin Author cactus.cloud

    (@bortpress)

    That’s all right, and understandable.

    Look, always run database backups before installing any plugin – as weird stuff can happen. However, there should be no reason for the plugin to actually change or damage the back end. If adding/removing the plugin changes the behaviour, then your site could be very close to its limit and merely pushed over the edge by the addition of another plugin. And if by any chance it is a rare error with the plugin, it’d be great to resolve it.

    If you try the plugin again, check in different browsers, as a combination of factors on your site can lead to a client side failure. Also, if you are using a caching plugin, be sure to clear your cache after each change.

    Also search for the error message you received in google. There are so many different factors that appear to cause that error (from browser settings, site settings, through to antivirus issues), and a lot of different solutions are provided. It would be valuable to confirm the source of the issue early so it doesn’t become a larger issue later on.

    There should not be any database overload caused by the plugin with its default settings – it would probably query 20 or 30 posts from the database at a time. Also, SQL is pretty resilient – I currently work with system that retrieves 1000s and sometimes 10,000s of rows at a time to perform some larger-scale operations. All these queries do is take a little longer.

    Perhaps there are some severe limits with your free webhost. It would be good to check the fine print there to see what you are allocated.

    I hope this helps somewhat

    There probably are some very sharp limits with my web host because its a free subscription xD. But I’m probably going to upgrade to premium soon (its running out of disk space), so once I do I’ll try again :).

    Thanks!

    OK so I’ve got it working again :D. For some reason when I removed Google AdSense it began to work again… maybe incompatibility? Is there a way to make these: http://s13.postimg.org/4mn2oxi9z/Untitled.png to all be the same size?

    Plugin Author cactus.cloud

    (@bortpress)

    Hey,

    What shortcode are you using? Also, do you have a link to the page?

    Cheers

    So I think I figured out the problem… My server installation was running WAY low on disk space because WordPress decided it wanted to create 12 copies of each image for some reason (which led to ~580 1920×1080 images)… so it was crashing the database. Fixing it now, hopefully it will fix (I was wrong about AdSense)

    Plugin Author cactus.cloud

    (@bortpress)

    Yeah, that can be a big problem.

    Do you have EWWW Image Optimizer by any chance? It’s good, but on it’s default setting will generate millions of random thumbnails causing a huge increase in your disk space.

    There’s a plugin called thumbnail cleaner that i’ve used to undo that in the past.

    I am using this shortcode: “[cactus-masonry masonry=”false” quality=”full” post_category=”videos” display_post_titles=”true” transitionDuration=”0s” crop_images=”true” fit_width=”true” width=”33.33%” max_width=”33.33%” height=”18.74%” max_height=”18.74%”]”

    I can PM you a link to the site if it is helpful, but I would rather not – my site is still in development and I’m trying to keep traffic off of my server until its done :).

    I do have two plugins that I’m using to try to shrink the images (to 348×216):
    1. Bulk Resize Images
    2. WP Smush

    I need these plugins because my YouTube importer (Automatic Youtube Video Posts) always imports the thumbnails at full resolution (1920×1080). Is there a better way to decrease disk usage?

    Thanks.

    Plugin Author cactus.cloud

    (@bortpress)

    Hey, I can see there that you have masonry set to false. That’s really a relic from early testing – which I really need to remove from the documentation.

    Also a percentage height will confuse the plugin and lead to some weird errors. Again, sorry, the new version of the documentation will be coming.

    I’m not sure of the layout you ultimately want, but here is a guess:

    [cactus-masonry display_post_titles="true" post_category="videos" width="33%" height="200px" crop_images="true"]

    I removed some of the redundant and conflicting parameters so it should be better now. If you check out the plugin site, there are also instructions on how to make the gallery responsive with CSS.

    Finally, be careful with the quality attribute. If you have a gallery of small images, then you only need to load the smaller version of the image. Loading larger images can increase server load and visitor wait times.

    WordPress automatically sets the thumbnail sizes, but you can change this. From your WordPress dashboard, select Options | Media. Here you can set the different thumbnail sizes that WordPress will use. Additionally, you can specify whether the smallest thumbnail size is cropped down or whether it should keep its original proportions.

    I hope that helps,

    Cheers

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Good’ is closed to new replies.