WordPress.org

Forums

Jetpack by WordPress.com
[resolved] og:url tag on *front page* links to a *post*? (7 posts)

  1. theonetruebix
    Member
    Posted 2 years ago #

    Hoping someone can explain to me why Jetpack's og:url tag on my blog's main page is set to a post instead of to the main blog URL. I had no idea until I tried to share my blog on Facebook and it got filled in with a link to a post, not to the site.

    http://furiousnads.com/

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Your site seems to be using another plugin to handle Open Graph Meta tags:
    http://i.wpne.ws/LvU0

    Have you managed to solve the issue by yourself?

  3. theonetruebix
    Member
    Posted 2 years ago #

    I disabled Jetpack's open graph stuff in order to use a different plugin for those tags, because as far as I know there's no way for me to tell Jetpack not to have a post's URL in that tag on the front page.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Jetpack uses the page permalink to build the Open Graph URL tag, so it should work correctly.

    Did you have any specific settings under Settings > Reading in your dashboard, or do you use any redirection plugins on your site?

  5. theonetruebix
    Member
    Posted 2 years ago #

    Actually, I see this in the latest release notes today: "Bug Fix: Publicize/Sharing: For sites without a static homepage, don't set the OpenGraph url value to the first post permalink." So there we go, then.

  6. theonetruebix
    Member
    Posted 2 years ago #

    Unfortunately, it's still broken, but now in a new way. In that "without a static homepage" circumstance (in other words, homepage is the blog), it's definitely no longer using the URL of the first post for og:url, but it's using the WordPress Address instead of the Site Address. So if my site is example.com and WordPress is installed in example.com/wp, Jetpack now uses the latter for og:url, which is still incorrect.

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    I have made a change to your account. Could you try to enable Jetpack Open Graph Meta tags again?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic