Support » Plugins and Hacks » [Resolved] og:title not working properly on category/taxonomy pages

[Resolved] og:title not working properly on category/taxonomy pages

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Chuck Reynolds


    do you use an seo plugin? this plugin just filters whatever metadata is being output; so if your install is just using the default title and no desc then it’ll just fake it and revert to basic stuff

    I am using All In One SEO Pack.

    However the title of the page is correct. Is only on categories (taxonomies are ok):

    Look this: http://www.informeclooney.com/madrid/categoria/lugares/cockteleria/

    The title there is: “Cockteleria en Madrid….”

    and if I debug it on Facebook:


    You would see that the og:title is “Evaristo” that is the first post of that page but the Title of the page is correctly.

    Plugin Author Chuck Reynolds


    well first off there’s another plugin adding some OGP stuff now which is duplicating tags but doesn’t include all the right stuff.

    <meta property=”fb:app_id” content=”159538290872515″/>
    <meta property=”fb:admins” content=””/>

    so need to fix that.

    This plugin is just pushing out <meta property=”og:title” content=”Evaristo”/> because it’s not getting anything from AIOSEO… all that plugin has is this..

    <!– All in One SEO Pack by Michael Torbert of Semper Fi Web Design[786,873] –>
    <link rel=”canonical” href=”http://www.informeclooney.com/madrid/categoria/lugares/cockteleria/” />
    <!– /all in one seo pack –>

    So it doesn’t seem you filled out the category meta info anyways.

    With all that said… I know my plugin is occasionally having filtering problems with allinone… I just haven’t had time to fix it but at least right now it looks like that plugin doesn’t have the proper info either.

    Hello there, I have the same problem here. I wasn’t using All in one SEO pack which seemed to be the causing conflict in the previous case.
    I was using the Add Meta Tags plugin (http://wordpress.org/extend/plugins/add-meta-tags/) + Facebook Open Graph Protocol but assuming the first could cause conflict too I deactivated it.
    Result when trying to share on facebook:

    1. category page title is loading the title of the latest post in the category
    2. category description (which I setted in the wordpress category edit page) seems to be overwritten by site description (which I setted in the wp general settings page)

    home page and single posts, instead, work just fine.
    I am just a beginner and have near-to-none knowledge in programming and php, so I may have done something wrong, but can’t figure out what.
    Thank you for any help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] og:title not working properly on category/taxonomy pages’ is closed to new replies.