Support » Plugin: Yoast SEO » og:image often doesn’t appear until post updated

  • Resolved DFC005

    (@dfc005)


    Can’t explain this one as it doesn’t always happen but we find that sometimes we’ll publish an article with a featured image. This works perfectly on the site with the featured image appearing where it should.

    But upon pushing this article to social media, we find that the card on Facebook and/or Twitter doesn’t show the featured image.

    Looking at the scraped data from Facebook, I can see that when this happens, there is no og:image tag in the data.

    If we update the post straight after posting, then this usually prevents the issue from happening.

    Is there something we can do to debug what might be causing this?

    • This topic was modified 1 month, 1 week ago by DFC005.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Your case similar with mine. I’m still waiting Yoast team to find the problem and solution.

    This works perfectly on the site with the featured image appearing where it should.

    Short story on my site, featured image ONLY appear as thumbnail. Inside article, usually I’m using other photo/image from external URL. But FB didn’t find og:image of featured image instead picking first image whatever appear inside the post. And just as you say update post are current solution. Not ideal.In old version Yoast, I could push publish button and let the system take the rest.

    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    Can you confirm that this issue is occurring with the latest version of WordPress 5.4.2 and Yoast SEO for WordPress 14.4.1?

    Just to clarify, you set a featured image for an article, but the og:image doesn’t use the featured image? Is this correct? When creating an article, could you check on the Social tab of the Yoast SEO meta box? It should select the featured image if you haven’t defined any other image specifically.

    Yes, using the latest version of WordPress and Yoast SEO.

    We set the featured image for the post and then publish the article. It seems in about 50% of cases though, when viewing the article after publishing, there is no og:image tag set in the header of the article. All other og tags look to be set correctly.

    If we update the article, then the og:image tag is set correctly.

    Plugin Support Carl B

    (@devnihil)

    @dfc005 Can you please provide us with an example URL of some of the pages where this issue is occurring, so that we can review the source code for any issues?

    Here is an example link: https://www.zerotackle.com/storm-set-for-extended-stay-interstate-updated-56613/

    Hard to see the issue as we are currently updated every article after posting to make sure it has the og:image tag added.

    I can try posting a test article (backdated a while to keep it off the homepage) if that might help but as previously stated, it doesn’t always happen either which is part of the frustration.

    Plugin Support Jerlyn

    (@jerparx)

    @dfc005 Just to isolate the issue more, when the issue happens again, instead of updating the article, can you please reset the indexable tables using the Yoast Test Helper plugin?

    We are trying to see if the issue you are having is similar to an issue that’s already been reported.

    We look forward to your response.

    OK. I was able to reproduce the issue 3/5 attempts at posting an article (just wanted to make sure it was still happening) by immediately visiting the new article in a separate browser that isn’t logged into WordPress.

    On those occasions, looking at the source code for the page there were no og:image tags.

    After installing the Yoast Test Helper plugin and running the “Reset indexables tables & migrations” I was not able to reproduce this issue after numerous attempts.

    We actually a few websites on this server all with the exact same setup (themes and plugins) and moving over to one of the other websites, I was still able to reproduce the issue at least 50% of the time.

    Does that suggest there is/was a problem with the “indexables tables & migrations” perhaps?

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Depending on your workflow if you create content on staging site and then push to live site, you may need to run the Reset Indexables button.

    However, we looked at a recent post: https://www.zerotackle.com/maroons-selector-reveals-three-contenders-no-9-jersey-55698/ and we can see Yoast is outputting the right og:image tag of: https://static.zerotackle.com/wp-content/uploads/2019/04/GettyImages-996064448.jpg.

    See image: https://pasteboard.co/JfkBuxR.png.

    Same with this link as well: https://www.zerotackle.com/storm-set-for-extended-stay-interstate-updated-56613/.

    We are not sure if this issue is solved or not? If the issue is happening can you please provide a link to a post/page that does not have the og:image tag?

    Well, it’s hard for us to do that as we can’t push the article to social media without the og:image tag as then it doesn’t present well.

    So as mentioned above, we’re currently in the process of being forced to update every single post to guarantee it has the correct tags (as this always resolves the issue).

    I’m currently investigating a theory that perhaps our caching plugin is creating a cached version of the page BEFORE Yoast SEO has added the og:image tag, as it seems when it happens if I view the page without the cache, the tag is correctly there.

    Going to try and run a few tests to see if I can make it happen without WP Rocket (our caching plugin) running

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    Please do let us know if you are able to reproduce the issue with the caching plugin disabled. If you have any other questions or concerns, please do let us know.

    I haven’t been able to give it a good test but a few quick attempts suggest that indeed, the caching plugin alongside Yoast is causing the issue.

    With WP Rocket disabled, I wasn’t able to reproduce the problem.

    Is it an issue with the order of the plugins doing their loading perhaps?

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    We’re not sure if the settings in your caching plugin may be causing this. Perhaps this article may be of further assistance — https://yoast.com/help/how-does-the-image-caching-work/

    So I assume no one else has reported this issue (or similar) and also been using a caching plugin? As you did mention there was a similar issue and you were trying to ascertain if mine was related.

    @omega8719 Do you use WP Rocket (or another) caching plugin?

    I swear this all used to work fine before the major upgrade to Yoast.

    Plugin Support Carl B

    (@devnihil)

    @dfc005 We checked for any similar reports in our repository and did find a similar report here: https://github.com/Yoast/wordpress-seo/issues/15246

    Can you please confirm whether this is essentially the same problem? If so, we would recommend commenting on the issue report.

    DFC005

    (@dfc005)

    @devnihil Yes, that looks like exactly the issue we’re experiencing. I’ve added a comment to that issue and will track it there as well. Cheers.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.