Support » Plugin: Thumb Fixer for Social Media » og:description for Home Page (only) shows code instead of description text

  • Other Set Up:
    Wordpress: 4.8.1
    Theme: X by Themeco
    Facebook Thumb Fixer: Version 1.7.5
    All in One SEO (free version)

    First, your plugin has solved a major problem I’ve with thumbnails Facebook has been showing on posts and the home page.

    When I click the Facebook share icon on the Home Page, the default image appears and beneath it is the page title then, instead of the page description it shows:

    [cs_column id= class= style=padding: 0px; ” />

    When I go to General Settings in the Dashboard and scroll down to the Facebook Thumb settings, my default image is correct, Homepage Object Type is set to “website” and when I click on “Homepage Preview” the website’s description text is there and not the code above.

    When I go the homepage to edit, if I have a featured image there and I click on “Preview” it shows the image, the title, a blank line where the description should be and the URL beneath that. The final result with the odd code is the same If I don’t have a featured image present but I can’t preview it of course.

    Things I’ve tried:
    > I looked at source code for the page and did not find multiple og:description tags

    > I spent time in Facebook Sharing Debugger repeatedly clicking on the “Scrape Again” button with no change, it still shows the code instead of the description.

    >The Sharing Debugger shows the og:description as:
    og:description [cs_column id= class= style=padding: 0px;

    >I’ve researched the forum and, although I’ve found other entries with this problem I did not find a solution.

    >I deactivated All in One SEO, cleared caches after every change before re-testing, but this did not help.

    >I checked the settings in X Theme and Open Graph is set to OFF so the theme will not output standard OG tags.

    Thank you for your help with this.

    • This topic was modified 3 years, 5 months ago by martycohen.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Michael Ott


    Hi Marty,

    It looks like your theme is doing the same thing as another theme (Divi) I’ve seen exhibit this behaviour.

    Without getting to techie on you, basically there is a WordPress function called strip_shortcodes() that as the name suggests, allows shortcodes to be stripped from returned content.

    But in the case for your theme and the other one I mentioned, the strip_shortcodes() function is not being honoured. So when you’ve got content that has a shortcode early on, it gets picked up in the open graph description (often truncated). In your case Facebook is seeing this:

    <meta property="og:description" content="[cs_column id= class= style=padding: 0px; "/>

    Notice the content is a partial shortcode.

    Why Divi and your theme takes issue with it though is a bit of a mystery. I’ve used the strip_shortcodes() function many times in different contexts over the years without issue.

    One user who relayed this issue to me recently had the same issue with Divi theme and he proposed a solution, but the solution was specifically for Divi and therefor not something I could really bake into an update.

    I realise this probably doesn’t help much, but it was worth explaining anyway.

    • This reply was modified 3 years, 5 months ago by Michael Ott.

    Thank you Michael. Not the answer I hoped for, but I’m curious why it does show properly when I go to General settings, then down to Home Preview?

    Plugin Author Michael Ott



    Good question.

    The preview is not actually being passed through an API or anything that could do an actual real preview (I’m pretty certain Facebook doesn’t have an API for that). Instead it’s just some trickery I created to show you what the result SHOULD look like.

    That said, now I think about it I don’t understand why you’re having the specific problem you are, given that the description is supposed to be taken from the Tagline field in General Settings. Unless you actually have some shortcode in that field? Might be worth checking.

    If that’s not the case then it’ll be your theme doing some shenanigans with that as well, though there’s probably a good reason why the theme developer chose to do that.

    • This reply was modified 3 years, 5 months ago by Michael Ott.

    I am having the same issue with the Elated Borderland ( WordPress theme. Just letting you know to help you track down the problem.

    Do you have any suggestions in the meantime? If I install another plugin, like Yoast, I will have to re-enter all of my descriptions.

    This just recently is an issue… I have been using your plugin for a while now, and it used to work fine. Something recently has introduced the shortcodes into the descriptions.

    We are using the Borderlands theme version 1.8, and they have a version 1.13 version available. Version 1.9 has a comment “Fixed Social Share Functionality” – I am going to try to update the theme… to see if that might fix the problem.

    Maybe this will help Marty with his issue…

    I’m having the same issue with the Pitch theme.



    Having just installed the plugin and run into the same issue with VC (I use Impreza theme which includes Visual Composer), there is a solution that is easy and worth a try:

    If you have an Excerpt for your page, the plugin will use that for the OG: Description field.

    Excerpts are not available for WP pages by default so you’ll need to force them on by adding this to your theme’s function.php file:

    add_post_type_support( ‘page’, ‘excerpt’ );

    The same thing will happen on posts too.

    You’ll need to make sure you have ‘Excerpts’ turned on in your WordPress dashboard Screen Options for pages.

    Works for me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘og:description for Home Page (only) shows code instead of description text’ is closed to new replies.