Support » Plugin: SEO Ultimate » OG Open Graph data not showing up on Facebook

  • The default meta tags are being displayed instead of the OG titles and description when the pages are shared on Facebook. How to fix this?

    WordPress 4.7.4
    SEO Ultimate Version 7.6.5.9

Viewing 2 replies - 1 through 2 (of 2 total)
  • use Open Graph Integrator setting (posts/pages) to input title and description properly under opengraph option. Use facebook debug option to check if everything is ok and Fetch new information, scrap the new data. here is the link to check https://developers.facebook.com/tools/debug/ . use your page or post link to Fetch new information, scrap new data and test. Share the link if it’s ok. Thanks.

    I have the same problem.

    I checked SEO >> Meta Description Editor. All of my posts have a meta description, but that description doesn’t get applied to the post. I tried to facebook debug, but the information it fetches remains wrong.

    I do have another plugin, Contextual Related Posts. If this plug-in is activated, the meta description changes to these related posts (like: “Read Further Title A Title B”). If I deactivate Contextual Related Posts, the description changes to the first few words of the post instead of the custom meta description I made. So the description I want to use is never applied…

    So the problem seems to be that SEO knows all of my meta descriptions and saved them correctly but still doesn’t apply them.
    Any tips on that? Thanks in advance!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘OG Open Graph data not showing up on Facebook’ is closed to new replies.