Support » Plugin: WP-Live Chat by 3CX » Offline send message not working

  • The form to send a message when no agents are online does not work. Pressing the “Send message” button does nothing. Please don’t mark this as resolved before it gets resolved.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I am having the same issue!

    • This reply was modified 3 months, 3 weeks ago by tristancrum.

    Same issue here.

    Hi @alexanderlabrie, @tristancrum, and @miksbl,

    Thank you all for reaching out to us, we do appreciate your time.

    Please, may I ask you all to please provide me with a link to your websites so that we can run a few tests from our side?

    This issue is most commonly due to a JavaScript conflict on the website which prevents the button events from being executed when clicked. We have seen this occur as a result of duplicate jQuery versions being present on the website.

    If preferred, you are welcome to open a support query with us directly on our website instead.

    We are eager to assist you in resolving this issue.

    Hi, I’have the same problem!
    the custom fields are seen, some are “required”, if someone does not enter anything, they still send the empty message (even if requested). Also the “email” field does not give any error message if someone writes the mail without (@). How can I solve it? Thank you

    Hi,

    We are having the same issue

    http://www.australiapackaging.com

    If you can please help.

    When we switch agent offline, we don’t have the offline message box appear it simply keep chat box and says “Please standby for Agent…..”

    Plugin Author wordpress3cx

    (@wordpress3cx)

    Hello everyone, this issue has been fixed on last version 8.1.3. Let us know!

    alexanderlabrie

    (@alexanderlabrie)

    Issue still present: please see my original post on this thread for the description.

    Plugin Author WP-LiveChat

    (@wp-livechat)

    @alexanderlabrie
    The form to send a message when no agents are online does not work. Pressing the “Send message” button does nothing.

    We’ve tested this pre-release and again now and can see it working. Could you elaborate with more information please?

    alexanderlabrie

    (@alexanderlabrie)

    Does it work if you try it on our site? https://shop.sphere.com.ai/

    I’m on the latest Chrome on Mac (v78).

    I can also try disabling all of our site’s plugins but need to make a backup first.

    Plugin Author wp3cx

    (@wp3cx)

    Hi @alexanderlabrie ,

    After checking your site, it seems that the source of the problem is not our plugin but a Javascript error produced by another plugin which breaks functionality.

    I have successfully submitted the offline form once I blocked the request to the JS file causing the problem.

    You can see in your browser’s Console which plugin it is. (seems to be a woo-commerce one).

    I hope this helps.

    alexanderlabrie

    (@alexanderlabrie)

    Thanks… it was due to our theme. I fixed the error and now it works.

    Plugin Author wp3cx

    (@wp3cx)

    Hi @alexanderlabrie ,

    Excellent! Thanks for providing the information needed to troubleshoot this.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.