Support » Fixing WordPress » oEmbed (Youtube) sometimes not working

  • Hello there,

    I can’t figure out why an embeded video using oEmbed sometimes works and sometimes not. It seems very random and I see no reason why one video would work and another one would not.

    May some of you encountered similar issue ?

    The only reason I could imagine is this could happen when the video embeded is very newly uploaded, but that doesn’t seem to be a good reason…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Rinku Y

    (@rinkuyadav999)

    If you are working in localhost and have not internet connection. video will not load. can you send web page link, if it is on live website.

    On localhost and with internet connection active, some videos display well, some not.

    With a good old fashioned iframe html code, the video will display, but with oEmbed… I just want to understand why oEmbed is sometimes so erratic.

    I don’t have a link to share, unfortunately.

    Basically, when the video is not displayed, the link is displayed.

    I have the exact same friggin problem – today is Monday June 13, 2017, running WordPress version 4.8.

    It’s on a local server (localhost) and the server have internet access (Uniform Server Zero – Internet Status is OK). WordPress is able to fetch plugins and install them too. (php_curl.dll must be ENABLED btw)

    I even did the exact same test you did in an HTML file with YouTube’s iframe embed code. Video works.

    But in a post/page, all I get are YouTube video links in plain text…

    Just found out that using HTTP instead of HTTPS works and the YouTube video gets embedded. I’ll be back with a solution, if I find one…

    If I link an HTTPS image, there’s no problem.

    • This reply was modified 1 month, 1 week ago by  sirusdark.
    • This reply was modified 1 month, 1 week ago by  sirusdark.

    I’m back! Now it works again….
    Possibly a plugin somehow messed up the oEmbed functionality…

    Cheers!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.