Support » Plugin: Pods - Custom Content Types and Fields » oEmbed Feature Not Working

  • Resolved adsoink

    (@adsoink)


    Hello!

    Been through each of the tutorials to embed YouTube, Vimeo, etc… via PODS, and the feature doesn’t seem to be working. Each and every attempt produces the same result in the admin, which is an error saying “Please input a correctly formatted oEmbed URL”. Nothing displays in the front end either.

    Per the documentation I’ve tried enabling shortcodes, the “special functions” for video, the tutorial from Web Design For Idiots (which has legacy PHP), WYSIWIG, et al. No method has produced a result.

    Any and all support is appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jim True

    (@jimtrue)

    Does it work with the URL you’re using in a WordPress regular editor? If it doesn’t, that’s WP, not Pods.

    Hey Jim,

    Thanks for the reply. The links function and embed with no issue in the regular WordPress editor.

    Plugin Author Jim True

    (@jimtrue)

    You’d have to open a Bug Report for this one, I’m afraid. Without exactly duplicating what you’re doing with your exact configuration of your Pod, we’d not be able to troubleshoot it without a Bug report:

    https://github.com/pods-framework/pods/issues/new/choose

    I never like to say ‘it works for me’, but I do have several websites with oEmbed fields using YouTube and Vimeo and it does ‘work for me’. That usually means you’ve got something else going on.

    Thanks for the reply, Jim.

    This has been examined in multiple ways –

    • Clean install of WP, all plugins, etc… in a staging environment, and the embed feature doesn’t function.
    • Deactivated all plugins and used the TwentyNineteen theme, and the embed feature doesn’t function
    • Attempted to embed via WYSIWYG, and the embed feature doesn’t function
    • Used the examples from the PODS website, and the embed feature doesn’t function

    Since our last exchange, the client has decided to take videos out of scope for now, and has asked that we move away from WordPress this year. For as much as I’d like to escalate a bug report and find a fix, neither time nor resources are available at present.

    Your time is appreciated.

    Plugin Author Jory Hogeveen

    (@keraweb)

    Hello @adsoink

    Attempted to embed via WYSIWYG, and the embed feature doesn’t function

    If this doesn’t work then I don’t thing embeds will work at all in your installation. The WYSIWYG editor is WordPress core, not Pods.

    I have had problems with embeds while using caching plugins. In any case, this is most likely a setup issue, not a Pods issue.

    Cheers, Jory

    Hi Jory,

    Thanks very much for replying, but please note that I mentioned above that embedding via WYSIWYG does work. It’s when the WYSIWYG editor is served by PODS that the embed feature breaks.

    To clarify our regression –

    • Clean install of WP using the TwentyNineteen theme and no other plugin installed other than PODS, the following was observed:
    • A PODS oEmbed field produced the error “Please input a valid oEmbed URL” on tab out of the field. On save, the URL input was no longer visible and was not inserted into the database.
    • Following the steps outlined here produced the same behavior as noted above
    • Changed the PODS field value to WYSIWYG which produced the same behavior
    • Followed instructions/suggestions from the PODS forums, and all failed to save the URL and produced the same error message.

    This behavior is not present when using the default WYSIWYG served by the WP core (either Gutenberg or the Classic Editor). Embeds function as expected.

    I would spend more time on this, though we are in the throes of moving our web assets out of WordPress. The crux of this ask was more or less to find a quick, easy fix to keep our assets looking fresh despite the transition.

    Plugin Author Jim True

    (@jimtrue)

    If you have time to type all of the above, you have time to file a Bug Report. Please do.

    This is not the appropriate place to discuss this. We’re not going to be able to work it with you through forums. We need the information requested in the Bug Report.

    Plugin Author Jim True

    (@jimtrue)

    Plugin Author Jory Hogeveen

    (@keraweb)

    Tested the oEmbed field locally and it works fine here (with YouTube).
    Indeed, please file the bug report so we can try to replicate your installation. Otherwise there is no way for us to reproduce your issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.