Support » Plugin: Order Splitter for WooCommerce » Odd issue

  • Resolved jonathansblog

    (@jonathansblog)


    Hi

    Thanks for the excellent plugin πŸ™‚
    I’m facing a weird issue – the plugin works fine, and my orders are split correctly – eg
    I have 2 products in my store (only 2 in the whole store)
    I only split the basket when it contains at least one of each product (that part works fine)

    The issue I have is when a user adds multiples of product1 and a (at least one) product2 (we collect custom metadata – their name on the product page) – in this scenario the metadata is copied incorrectly:

    Instead of:
    ———————–
    original:
    product1: name1
    product1: name2
    product2: name3

    split1
    product1: name1
    product1: name2

    split2
    product2: name3
    ———————

    I’m getting:

    original:
    product1: name1
    product1: name2
    product2: name3

    split1
    product1: name2
    product1: name2

    split2
    product2: name3
    ———————

    what appears to be happening is that the metadata associated with the product1 is being replaced by the last instance of the metadata for that product, eg if I have the following:

    original:
    product1: name1
    product1: name2
    product1: name3
    product1: name4
    product1: name5
    product1: name6
    product1: name7
    product2: name8

    I end up with:

    split1
    product1: name7
    product1: name7
    product1: name7
    product1: name7
    product1: name7
    product1: name7
    product1: name7

    split2
    product2: name8
    ———————

    data on the thank-you page is correct, and data in the email is correct, but on looking in the database, the data in the database is incorrect – I suspect there may be a loop updating on a product-id instead of an item-id somewhere in the code?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.