Support » Fixing WordPress » Odd Error Message when uploading images

  • Resolved rickibird

    (@rickibird)


    I’ve just today uploaded and installed WordPress 2.7 and am having an issue when uploading, or attempting to upload images. The image begins to load and then stops and I get the following error message:

    Unable to create directory /usr/local/pem/vhosts/100994/webspace/httpdocs/wp-content/uploads/2009/01. Is its parent directory writable by the server?

    Can anybody help me out with this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I managed to resolve this.

    I created a folder in wp-content folder, called it “uploads” and gave it 777 permissions. Worked perfectly . . . for now at least :o\

    I think lots of people have been having this problem. The fix I found was to change your Upload path in Settings > Miscellaneous. Change it to: wp-content/uploads

    That should upload to the correct folder. But, I’m still having problems with inserting images into posts. I get a blank screen when I click “Insert in Post”, and the image does not get inserted. Still looking for a solution.

    Thanks popart, your fix is a little more elegant than mine.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Odd Error Message when uploading images’ is closed to new replies.