WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Odd Behavior – https reverts to http in the add plugin navigation

[Resolved] Odd Behavior – https reverts to http in the add plugin navigation

  • rtcunningham
    Participant

    @rtcunningham

    I successfully made everything work with SSL on an alternate port. The only issue I can see is that when I use the “add new” plugin option, only the first page is https. The navigation (with “paged=2”, etc.) doesn’t pick that up and of course, doesn’t work.

    I’m using NginX and I don’t have any problems with rewrites, but this has me stumped. It seems to be something within the WordPress code, but I’m at a loss as to where to look.

    I reverted back to not using SSL at all because of this single issue. I can’t use the standard port because of multiple WordPress installations on the same IP address.

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mike Ems
    Member

    @mvied

    I’m assuming you’re using WordPress HTTPS, but you didn’t actually say. Are you?

    rtcunningham
    Participant

    @rtcunningham

    Yes. I couldn’t use an alternate port otherwise.

    Plugin Author Mike Ems
    Member

    @mvied

    I can’t reproduce this issue. Could you tell me if this happens with the development version?

    rtcunningham
    Participant

    @rtcunningham

    I don’t know when I’ll have the time, but I’ll check.

    rtcunningham
    Participant

    @rtcunningham

    Okay, I tested it and it still doesn’t work. By the way, I was confused by the lack of a port number box until I added the port number to end of the SSL domain.

    It’s really odd because my rewrite rule says to rewrite anything with /wp-admin/ in it. Could it be because WordPress uses force_ssl_admin (or lack thereof) to write those URLs?

    In the meantime, perhaps I need to limit my rewrite rule for logging in only.

    Plugin Author Mike Ems
    Member

    @mvied

    If you didn’t install it through the Dashboard, you have to deactivate/reactivate the plugin to run the install/upgrade process. I moved the port out of its own field, that’s why your port was missing.

    It’s just a bug somewhere in the code. Not sure where, though.

    rtcunningham
    Participant

    @rtcunningham

    I found the problem and it isn’t your plugin. The default fastcgi_params file for NginX doesn’t include:

    fastcgi_param HTTPS on;

    It took me a lot of searching through bug reports to find it. Once I added that, all of the URLs suddenly worked as expected. Perhaps you may want to add that to the FAQ somehow.

    rtcunningham
    Participant

    @rtcunningham

    By the way, the development version of the plugin works perfectly (for me).

    Plugin Author Mike Ems
    Member

    @mvied

    You should have had a lot more issues than that if that was the fix. At least you got it working.

    I try to leave the server configuration up to the user and their hosting provider. If the server isn’t correctly reporting that the page is HTTPS, there’s really nothing I can do about it. The plugin has an entry in the debug log called “SSL: Yes/No” that helps identify this issue. If it says No on an HTTPS page, the server is set up wrong. I have limited time to develop and support the plugin, so I try to focus on people having issues with the plugin directly.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Odd Behavior – https reverts to http in the add plugin navigation’ is closed to new replies.