Support » Theme: OceanWP » OceanWp settings doesn’t show on CPT template

  • Resolved danikar

    (@danikar)


    Hi,

    I created CPT called portfolio. Then I created custom Template which is set to have content layout 100% full width and Display Page Title to “Disable”. This works.

    But then, when i apply the template, the page that uses it still has Page Title and Sidebar, and it is not full width.

    Can you please help me to have the page without Page Title, Sidebar and be Full Width?

    Thank you!!

    • This topic was modified 7 months, 2 weeks ago by danikar.
    • This topic was modified 7 months, 2 weeks ago by danikar.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The feature you request is a premium add-on plugin for oceanwp. (the theme that you are using) This is not available in the free version without modification of the underlying php files.

    The Pro version is in a state of flux right now. I couldn’t say what will work or what won’t. He’s in the process of changing the licensing over to something called freemius. What I’ve seen of freemius so far doesn’t work properly. (At least for those who have unimited oceanwp. Maybe it’s just because it’s in progress and they will get the wrinkles ironed out of it pretty quick. In the meantime I’m glad that I also have Astra.

    Hello,

    1. For the layout of custom post types –

    Add below code to the oceanwp child theme’s functions.php file to make it full-width –

    function my_post_layout_class( $class ) {
    	if ( is_singular( 'portfolio' ) || is_archive( 'portfolio' ) ) {
    		$class = 'full-width';
    	}
    	return $class;
    }
    add_filter( 'ocean_post_layout_class', 'my_post_layout_class', 20 );

    2. To remove the page title from portfolio page, add the below code the child theme’s functions.php file –

    function disable_protfolio_page_title( $return ) {
        if ( is_singular( 'portfolio' ) || is_archive( 'portfolio' ) ) {
            $return = false;
        }
        return $return;
    }
    add_filter( 'ocean_display_page_header', 'disable_protfolio_page_title' );

    Thank you so much for your help. I’m going to try Astra : )

    Okay, no problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘OceanWp settings doesn’t show on CPT template’ is closed to new replies.