Support » Theme: OceanWP » Ocean Elementor Widget Plugin conflicts with Elementor Plugin

  • Hello,

    Recently I was having trouble opening elementor editing screen. It was showing 500 error and in the debug log it says-

    The site is experiencing technical difficulties.

    Uncaught TypeError: Argument 1 passed to Elementor\Controls_Stack::sanitize_settings() must be of the type array, null given, called in /home/bohubrih/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php on line 1022 and defined in /home/bohubrih/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php:1933
    Stack trace:
    #4 /home/bohubrih/public_html/wp-content/plugins/ocean-elementor-widgets/modules/button-eff

    Then I deactivated ‘ocean elementor widgets’ plugin and then elementor did launch successfully. Activating the elementor widget plugin brings back the issue.

    It’s probably after the latest updates of either plugins –
    I am using Elementor version 2.6.8
    Ocean Elementor Widgets version 1.1.5
    and OceanWP version 1.6.10

Viewing 10 replies - 1 through 10 (of 10 total)
  • I got the same issue
    Ocean Elementor Widgets version 1.1.5
    Elementor 2.6.8

    Hello,

    Try to update the Ocean Elementor Widget plugin to v1.1.8 to fix the issue.

    Thread Starter Yanur Islam Piash

    (@yipiash)

    My subscription to ocean core extension bundle has expired recently. So the latest version of the plugin is right now inaccessible for me.

    Unfortunately, we can’t do anything in this case. Also, since it is a premium plugin, please contact the support on oceanwp.org.

    Hi,
    I experience the same issue. Running Ocean Elementor Widgets version 1.1.6.

    You said that updating it to 1.1.8 would fix it. How do I do that? Most plugins have an “update” option but there is no Update option in the Plugins’ Dashboard.

    Thank you!

    Hello,

    Since we have switched to freemius, then you need to update the plugin manually for the first time. After that, you will get update notification within the dashboard.

    Since we have switched to freemius, then you need to update the plugin manually for the first time. After that, you will get update notification within the dashboard.

    I don’t understand this. I am having the same issue that others have mentioned above. I have a paid-for version of the Ocean Theme, the extensions, and Elementor Pro… But the Ocean Elementor Widget plugin is clashing with Elementor. Why won’t it update? And how do I make it update manually?

    In V1.1.6 change the file modules/button-effects/widgets/button-effects.php

    arround line 35 the function to this:

    public function get_style_depends() {
    global $settings;
    if ( ! \Elementor\Plugin::$instance->editor->is_edit_mode() && ! \Elementor\Plugin::$instance->preview->is_preview_mode() ) {
    $settings = $this->get_settings();
    }
    return [ ‘oew-button-effects’, ‘oew-‘. $settings[‘effect’] ];
    }

    and then the same for file modules/link-effects/widgets/links-effects.php

    public function get_style_depends() {
    global $settings;
    if ( ! \Elementor\Plugin::$instance->editor->is_edit_mode() && ! \Elementor\Plugin::$instance->preview->is_preview_mode() ) {
    $settings = $this->get_settings();
    }
    return [ ‘oew-link-effects’, ‘oew-‘. $settings[‘effect’] ];
    }

    Then elementor will load fine.

    Hope this helps for you and 1.1.6 = 1.1.x up to 1.1.9 without the bloat…

    Since we have switched to freemius, then you need to update the plugin manually for the first time. After that, you will get update notification within the dashboard.

    I purchaced the Ocean Theme and Elementor Pro- how can i get the updated plugin ?

    @apprimit

    Do we need to manually update other OceanWP plugins/add ons as well?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Ocean Elementor Widget Plugin conflicts with Elementor Plugin’ is closed to new replies.