Support » Plugin: Antispam Bee » obsolete code detected

  • Resolved DJIO

    (@djio)


    Hi there!

    I was running Debug Bar to detect an error on my theme but I came across this warning on Deprecated Calls tab.

    I ran a sitewide search and found your plugin using levels intead of capabilities, so
    antispam_bee.php line 670 is:

    if ( !current_user_can(‘level_2’) or !self::get_option(‘dashboard_chart’) ) {

    but it should be:

    if ( !current_user_can(‘publish_posts’) or !self::get_option(‘dashboard_chart’) ) {

    Please change that for the next version
    😉

    Best regards,
    Cheers from Brazil

    Djio

    http://wordpress.org/extend/plugins/antispam-bee/

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘obsolete code detected’ is closed to new replies.