Support » Plugin: Theme My Login » Observing lostpassword invalid key problem when caching is disabled

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeff Farthing

    (@jfarthing84)

    Can you update to TML 6.4.17?

    Thanks for quick reply.
    I have updated to TML 7.0.10 and for reset password, still same problem occurs.
    In desktop,it redirects to reset password page.
    When I click reset password link in email on mobile,it is redirecting to lost password page.

    Plugin Author Jeff Farthing

    (@jfarthing84)

    As far as the plugin is concerned, there is no difference between desktop and mobile. Unless you have cookies disabled on mobile?

    Cookies are enabled on mobile.I disabled all plugins,and changed theme.Manually replaced wordpress version with new one.Still no change.Any other thing to check?

    Finally i got the solution.
    The problem is in reset password link.
    Closing ‘>’ is might becoming part of link parameter.
    Go to plugin theme-my-login/includes/compat.php,
    search for following line:
    $message .= ‘<‘ . network_site_url( “wp-login.php?action=rp&key=$key&login=” . rawurlencode( $user->user_login ), ‘login’ ) . “>\r\n”;

    Modify it as:
    $message .= network_site_url( “wp-login.php?action=rp&key=$key&login=” . rawurlencode( $user->user_login ), ‘login’ );
    Then retest your lost password functionality.Now it is working on both mobile and web.

    Also seeing this error. And in addition, anyone using Microsoft Outlook clients are not able to click the link. They have to copy and paste it, invariably WITH the stray HTML closure tag at the end.

    wp-content/plugins/theme-my-login/includes/compat.php

    Removing the stray ‘<‘ and ‘>’ from the above file on line 91 worked for us.

    $message .= '' . network_site_url( "wp-login.php?action=rp&key=$key&login=" . rawurlencode( $user->user_login ), 'login' ) . "\r\n";

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.