WordPress.org

Forums

WP Offload S3
[resolved] object path not updating (11 posts)

  1. princebonam
    Member
    Posted 1 year ago #

    Hi,

    For the object path in the editable field I have:

    wp-content/uploads/

    but after that in an area that I can't edit it has:

    /2014/02/

    Which I'm guessing is for this month since I installed it then.

    The problem is when I upload to any older directory all the images automatically go into 2014/02 instead of anything older such as 2013.

    How do I remove the 2014/02 so everything gets uploaded to it's proper directory?

    Thank you in advance!

    https://wordpress.org/plugins/amazon-s3-and-cloudfront/

  2. TraciBunkers
    Member
    Posted 1 year ago #

    What do you mean when you upload to an older directory? Whenever you add to your media library, wordpress automatically uploads into a folder for the month of when you are uploading it--so that date will always be the current month. This is a wordpress thing.

    If you are manually uploading into an older folder, then this plugin has nothing to do with that.

    But maybe I'm not understanding what you are trying to do.

  3. princebonam
    Member
    Posted 1 year ago #

    It's fine when I upload to wordpress but I'm talking about when it goes from WP to S3. In S3 it uploads everything in this months folder instead of creating folders for 2013 and the months in there.

  4. TraciBunkers
    Member
    Posted 1 year ago #

    Even if you are replacing photos for old posts by going into the posts, it will upload the photos into a folder for the current month--same as wordpress does.

    If you are wanting to move older media into S3, you can do it manually, then use a plugin like Velvet Blues Update URLs to change all of the URLs in the posts/pages to point to the new URL. I did that. The only draw back is that then from the admin side, when looking at your media library, you can't see the thumbnails. When this plugin moves the files to S3, it inserts code into the database about the new location. I haven't figured out how to do that manually. But from the readers side, everything is fine.

  5. princebonam
    Member
    Posted 1 year ago #

    Thank you!

    I've gone ahead and moved them in manually but the url WP is looking for is cloudfront but my images are in S3. Is there anything you had to do to make them sync to show up on the site?

  6. TraciBunkers
    Member
    Posted 1 year ago #

    Yes, your images are in your S3 bucket. And I assume you are using cloudfront. So you should already have a distribution set up for that S3 bucket that you created when you installed this plugin. So your cloudfront distribution will find the images in your S3 bucket. Here's a link that's a tutorial for setting all of this up: http://blog.celingest.com/en/2013/07/19/tutorial-creating-cdn-wordpress-cloudfront-s3/

  7. princebonam
    Member
    Posted 1 year ago #

    Thank you Traci!

    I actually went through that same tutorial but just noticed this:

    "We have to keep in mind that any files uploaded before installing the plugin won’t be transferred to S3 nor CloudFront and will keep being served from the instance running WordPress"

    What did you do to get around that? I used the velvet blues already but it's not picking images directly.

    Thank you!

  8. TraciBunkers
    Member
    Posted 1 year ago #

    Right--the info for this plugin says it doesn't upload any media to S3 that's already in your media library, and I mentioned in an earlier response that you have to do that manually. I uploaded my "old" media to my S3 bucket, then used velvet blues to change the URLs on my site.

    If velvet blues isn't finding any images, then you must not be putting in the correct URL for where they originally were in your uploads folder (or where ever they originally were).

  9. princebonam
    Member
    Posted 1 year ago #

    Thank you Traci!

    I didn't change anything and all of a sudden all the images are showing up. I guess it was some sort of strange caching issue. Anyway, thank you very much for all your help! :)

  10. TraciBunkers
    Member
    Posted 1 year ago #

    Glad it's working for you! I always try to remember to turn off my caching plugin when I'm making changes because sometimes it'll still show the old version. But I don't always remember to do it.

  11. weizhuus
    Member
    Posted 1 year ago #

    I am going through the same process now. Any way to solve the thumbnail issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Offload S3
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.