Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » [object Object] shown where cookie settings should be

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor jarnovos


    Hi @wp_user1,

    The problem is that you likely have a plugin or setting that limits access to the REST API, for instance, when the user is not logged in.

    This has the result that the “Manage Consent” section can not be loaded correctly, and [object Object] appears instead.

    The behavior will be resolved by removing that restriction from the REST API.

    Kind regards,

    Thread Starter wp_user1


    Hey Jarno,
    it seems like the problem only occurs in some browsers.

    We see the settings in Firefox and Safari.
    But Chrome and Edge do show the [object Object] code..

    While loading we get for a few seconds a message:
    “loaded without JavaScript-support.”

    This message disappears and then the [object Object] appears.

    • This reply was modified 11 months, 4 weeks ago by wp_user1.
    Thread Starter wp_user1


    Okay, it was a problem with CleanTalk setting.

    For other people with the same problem, it was this setting:
    “Disable REST API for non-authenticated users”

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[object Object] shown where cookie settings should be’ is closed to new replies.