WordPress.org

Support

Support » How-To and Troubleshooting » [object Object] error on all new posts

[object Object] error on all new posts

  • This morning when I tried to create a new post, with nothing fancy in it, I received an error, when I clicked the “Save Draft” button that read:

    [object Object]

    That error displays when the page reloads. My post content is gone and in its place is the above error message. This now happens with every post I create. I’ve updated all of my active plugins and from Google searches found that this can sometimes be attributed to a jQuery issue, but other than that I’m lost.

    I know it sounds cliche, but I didn’t change anything. The post I was writing had a paragraph of text and an unordered list of about 20 items, each list item had a link and that’s it. The last thing I did in WP was typing up and scheduling two posts and that process went smoothly.

    Does anyone have any ideas what else I could try to fix this?

    Thanks in advance!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Argh. I just started getting this exact problem too. I contacted my webhost too to see if it was on their end and they said no. He logged into my blogs and was able to create and publish new posts without that [object object] tag but when I would go and try to even update his test post I would get it again.

    He just said it was something on my PC. This is happening on more than one wordpress blog that I have too. I went and merely edited a previous post on another blog and the content was wiped and replaced with that tag.

    Deguia, who is your webhost? Mine is Hostgator. Just curious if it is a database issue since it is happening all of a sudden on more than 1 blog.

    Same here and I am hosting with Hostgator also. They disabled magic_quotes for some upgrades and I thought that might be the problem but when I re-enabled magic_quotes it didn’t make any difference.

    I have several wordpress blogs with Hostgator and none of them work now.

    Same problem here.

    It is not a database issue. I modified my posts directly within my database without any problems.

    For a temporary solution:

    1: Create a new post and just enter the title.
    2: Publish the post and then edit it, adding the content.
    3: Wait for about 1-2 minutes, allowing the post to autosave.
    4: Select “Update Post”.
    5: When it is finished updating, go down to the “Post Revisions” and select the most recent “[autosave]”.
    6: On the revisions page, select “Restore” next to the “[Autosave] by Author”.

    This is a nasty, temporary fix, but it should work until we figure out the issue.

    Try turning off “Google Gears”.
    If you are running Turbo, turn it off. I am pretty sure that is the issue.

    If you are not running Turbo and this is occurring, I would be interested to know…

    same with me, but I use Midphase/AN hosting so I don’t think the host is the issue.

    thanks for the temporary fix. This happened on a day that a post I did went viral on stumbleupon. My heart has not stopped beating from the rush of fear as I watched my posts be erased. ahhh!

    Try turning off “Google Gears”.
    If you are running Turbo, turn it off. I am pretty sure that is the issue.

    I do not have that installed so it’s gotta be something else for me.

    Anyone running Zemanta?
    I was mistaken about Gears, it is Zemanta.
    (I disabled both)

    sadly, Google Gears was not the issue for me.

    yes, I am running Zemanta. I noticed that about two days ago they changed some of the embedded code in their images, which prevented a text wrap. I had to go into the html and replace the float left command.

    wonder if they changed something else?

    I’ll go take Zemanta out now.

    cebeninati:
    I can’t find where to disable Zemanta. Advice?

    Thank you SOOO much btw.

    If you are running Firefox, disable it from Tools>Add-Ons.

    If you are using the Zemanta plugin, then from your dashboard, go to Plugins and disable Zemanta. (I think it is only an issue with the firefox add-on though.)

    Anyone running Zemanta?
    I was mistaken about Gears, it is Zemanta.
    (I disabled both)

    Can I have your babies? That was it! Thanks soooo much! 😀

    Oh sweet relief! Taking out Zemanta fixed it. Thank you thank you!!!

    Glad to do my civic duty 🙂
    You can thank me by checking out my blog: http://www.cbeninati.com 🙂

    I have contacted Zemanta, and we will hopefully see a fix soon.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[object Object] error on all new posts’ is closed to new replies.
Skip to toolbar