WordPress.org

Ready to get started?Download WordPress

Forums

[object Object] error on all new posts (20 posts)

  1. deguia
    Member
    Posted 5 years ago #

    This morning when I tried to create a new post, with nothing fancy in it, I received an error, when I clicked the "Save Draft" button that read:

    [object Object]

    That error displays when the page reloads. My post content is gone and in its place is the above error message. This now happens with every post I create. I've updated all of my active plugins and from Google searches found that this can sometimes be attributed to a jQuery issue, but other than that I'm lost.

    I know it sounds cliche, but I didn't change anything. The post I was writing had a paragraph of text and an unordered list of about 20 items, each list item had a link and that's it. The last thing I did in WP was typing up and scheduling two posts and that process went smoothly.

    Does anyone have any ideas what else I could try to fix this?

    Thanks in advance!

  2. Sarasayshi
    Member
    Posted 5 years ago #

    Argh. I just started getting this exact problem too. I contacted my webhost too to see if it was on their end and they said no. He logged into my blogs and was able to create and publish new posts without that [object object] tag but when I would go and try to even update his test post I would get it again.

    He just said it was something on my PC. This is happening on more than one wordpress blog that I have too. I went and merely edited a previous post on another blog and the content was wiped and replaced with that tag.

    Deguia, who is your webhost? Mine is Hostgator. Just curious if it is a database issue since it is happening all of a sudden on more than 1 blog.

  3. atlascopy
    Member
    Posted 5 years ago #

    Same here and I am hosting with Hostgator also. They disabled magic_quotes for some upgrades and I thought that might be the problem but when I re-enabled magic_quotes it didn't make any difference.

    I have several wordpress blogs with Hostgator and none of them work now.

  4. cbeninati
    Member
    Posted 5 years ago #

    Same problem here.

    It is not a database issue. I modified my posts directly within my database without any problems.

    For a temporary solution:

    1: Create a new post and just enter the title.
    2: Publish the post and then edit it, adding the content.
    3: Wait for about 1-2 minutes, allowing the post to autosave.
    4: Select "Update Post".
    5: When it is finished updating, go down to the "Post Revisions" and select the most recent "[autosave]".
    6: On the revisions page, select "Restore" next to the "[Autosave] by Author".

    This is a nasty, temporary fix, but it should work until we figure out the issue.

  5. cbeninati
    Member
    Posted 5 years ago #

    Try turning off "Google Gears".
    If you are running Turbo, turn it off. I am pretty sure that is the issue.

  6. cbeninati
    Member
    Posted 5 years ago #

    If you are not running Turbo and this is occurring, I would be interested to know...

  7. acmj2
    Member
    Posted 5 years ago #

    same with me, but I use Midphase/AN hosting so I don't think the host is the issue.

    thanks for the temporary fix. This happened on a day that a post I did went viral on stumbleupon. My heart has not stopped beating from the rush of fear as I watched my posts be erased. ahhh!

  8. Sarasayshi
    Member
    Posted 5 years ago #

    Try turning off "Google Gears".
    If you are running Turbo, turn it off. I am pretty sure that is the issue.

    I do not have that installed so it's gotta be something else for me.

  9. cbeninati
    Member
    Posted 5 years ago #

    Anyone running Zemanta?
    I was mistaken about Gears, it is Zemanta.
    (I disabled both)

  10. acmj2
    Member
    Posted 5 years ago #

    sadly, Google Gears was not the issue for me.

  11. acmj2
    Member
    Posted 5 years ago #

    yes, I am running Zemanta. I noticed that about two days ago they changed some of the embedded code in their images, which prevented a text wrap. I had to go into the html and replace the float left command.

    wonder if they changed something else?

    I'll go take Zemanta out now.

  12. acmj2
    Member
    Posted 5 years ago #

    cebeninati:
    I can't find where to disable Zemanta. Advice?

    Thank you SOOO much btw.

  13. cbeninati
    Member
    Posted 5 years ago #

    If you are running Firefox, disable it from Tools>Add-Ons.

    If you are using the Zemanta plugin, then from your dashboard, go to Plugins and disable Zemanta. (I think it is only an issue with the firefox add-on though.)

  14. Sarasayshi
    Member
    Posted 5 years ago #

    Anyone running Zemanta?
    I was mistaken about Gears, it is Zemanta.
    (I disabled both)

    Can I have your babies? That was it! Thanks soooo much! :D

  15. acmj2
    Member
    Posted 5 years ago #

    Oh sweet relief! Taking out Zemanta fixed it. Thank you thank you!!!

  16. cbeninati
    Member
    Posted 5 years ago #

    Glad to do my civic duty :)
    You can thank me by checking out my blog: http://www.cbeninati.com :)

    I have contacted Zemanta, and we will hopefully see a fix soon.

  17. cbeninati
    Member
    Posted 5 years ago #

    I have just received an email from Zemanta:

    we've just fixed this. Please clear cache and restart browser and it's
    going to work.

    We're really sorry for this.

    A+ for Zemanta's prompt fix!

  18. acmj2
    Member
    Posted 5 years ago #

    sweet....

    and your blog is awesome. added to my reader and reading list.

  19. deguia
    Member
    Posted 5 years ago #

    Thanks for the responses, all!

    When I updated my plugins there was an update for Zemanta, which I applied and the problem kept happening. Since posting, I've found that the problem is only happening now when I create a post and try to save it as a draft. I can create posts and push them live from the standard new post window as well as the "quick post" area.

    I'll try some of the suggestions and see what happens.

    Thanks again!

  20. Mariokluser
    Member
    Posted 5 years ago #

    Nonetheless Zemanta is making meatballs of my AdSense code.

    Going to disable this. Thanks for your input guys!

Topic Closed

This topic has been closed to new replies.

About this Topic