Support » Plugin: W3 Total Cache » object cache plugin (redis)

  • Resolved benlee

    (@benlee)


    Hi, I was using breeze as cache plugin and moved to w3 total plugin.
    I was using redis plugin continuously from the beginning.

    But these messages continue to come out. (The Object Cache add-in file object-cache.php is not a W3 Total Cache drop-in. Remove it or disable Object Caching.)

    When entering “redis setting,” everything comes out well connected. “flush functoin” is also going well., but whenever I press “purge all cache”, an error warning phrase appears.

    I searched solution about it. someone said, “download new object-cache.php file, and put it in the right path, and click remove it on the warning banner” => I tried, but the warning keeps coming up.
    I wanna know how to fix this issues, my 2 other sites have the same symptoms like this.

    And I asked my hosting service team, and they newly named the “old object php. – cache” but kept warning labels -so i ask this plugin service team now.

    • This topic was modified 2 months ago by benlee.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @benlee

    Thank you for reaching out and I am happy to assist you with this.

    The Object Cache add-in file object-cache.php is not a W3 Total Cache drop-in. Remove it or disable Object Caching.

    This indicates that some other Object Caching plugin was used, and the object-cache.php drop-in was added by that other plugin.
    Once you installed W3 Total Cache and enabled the Object Caching, W3TC recognized that the drop-in is not added by W3 Total Cache which may cause the conflict.
    I would recommend disabling Object Caching in Performance>General settings, saving all settings, and purging the cache. Next, manually delete the object-cache.php from /wp-content/, and then, re-enable Object Caching in W3 Total Cache settings, save all settings and purge the cache and see if the problem persists.

    I hope this helps!

    Thanks!

    Thread Starter benlee

    (@benlee)

    Thanks for replying. I did what you said. But the problem persist.

    So, I re-checked if object-cach.php (Just deleted from /wp-content/) is exist.

    I regenerated again, So the problem persist.

    Should i move this file to /plugin/w3-totalcache/wp-content/ ?

    There’s 2 object-cache.php files
    1. /wp-content/
    2. /wp-content/plugin/w3-totalcache/wp-content/

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @benlee

    Thank you for the information.
    The file that needs to be deleted is the one in /wp-content/. The other file you are mentioning is the actual file that should be dropped in the /wp-content/ so you can try to copy the file from /wp-content/plugin/w3-total-cache/wp-content/ and paste it to /wp-content/, go back to the dashboard and save all settings and purge the cache.
    IF this does not work, then I would advise completely removing W3 Total Cache and re-installing the plugin:
    1. Purge Cache
    2. Deactivate and Delete Plugin
    3. Check .htaccess File (make a backup)
    W3TC will create many directives in .htaccess file to control the caching behavior. Each section will start and end with comments like “#BEGIN W3TC Page Cache core” and “#END W3TC Page Cache core”.
    Ensure that no residual entries are left over in your .htaccess file after deleting the plugin.
    4. Delete wp-content files and folders
    – cache folder
    – w3tc-config folder (make a backup)
    – object-cache.php (if exists)
    – advanced-cache.php (if exists)
    – db.php (if exists)
    – upgrade folder
    – delete w3-total-cache folder in wp-content/plugins/ (if exists)
    5. Delete Cached Files from CDN (if using CDN)
    Besides deleting all the relevant files, if you use CDN then ensure to purge the cached content from your CDN. This is necessary when you enabled minify option in W3TC settings. You should delete the minified and combined scripts and CSS files from your CDN server to avoid the site breaking on the browser.
    6. Go to your wp dashboard and re-install W3 Total Cache

    I hope this helps!

    Thank you!

    Thread Starter benlee

    (@benlee)

    Thank you for replying. Thank you very much

    I copy “object-cache.php file (size : 4KB)” and I paste this to /wp=content/. and then i purge all cache, and I checked again /wp-content/.

    object-cache.php file (size : 4kb) automatically changed to object-cache.php file (Size : 80kb; redis object-cache file). so the problem is not solved.

    before completely removing this plugin. I just wanna ask if this redis plugin works fine though it is not drop-in w3 total cache.

    my little thought, I guess my hosting(cloudways) manages the Redis plug-in, and I wonder if this redis plug-in works well in this state anyway. Even if it was not completely linked to the w3 plug-in.

    cause I’m not confident solving the problem after I delete and re-install w3 total plugin. ( my other 2-3 sites has the exact same issues so i guess re-installing’s not gonna work….)

    If this object-caching is okay with functioning and okay with being managed by cloudways server side, please tell me. I can ignore the drop-in warning sign.

    If object cache function is not working, I would try deleting and following what you said

    * For your information, in diagonostic section’s drop-ins info :

    Ignored Groups: [
        "counts",
        "plugins",
        "themes",
        "wordfence",
        "wordfence-ls"
    ]

    Drop-ins: [
    “advanced-cache.php v by “,
    “db.php v by “,
    “Redis Object Cache Drop-In v2.0.21 by Till Krüss”
    ]

    * Redis Overview (though, drop-in warning sign shows up) :
    Client: PhpRedis (v5.3.4)
    Drop-in: Valid
    Key Prefix: wffanywzsn
    Connection
    Status: Connected
    Host: 127.0.0.1
    Port: 6379
    Database: 0
    Connection Timeout: 1s
    Read Timeout: 1s
    Redis Version: 5.0.3

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @benlee

    Thank you for the information and clarification.
    Just to confirm, you are using another plugin “Redis Object Cache” besides W3 Total Cache?
    If you are using the mentioned plugin, you should definitely disable W3 Total Cache Object caching to avoid conflict. This will remove the notification and Redis Object Cache will be handling Object Caching.
    You should not use two different plugins for Object Caching.
    Let me know if this helps!
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.