Support » Plugin: Redis Object Cache » Object cache could not be enabled

  • Resolved antsomers

    (@antsomers)


    Hello. Thank you for great plugin. My system is Debian Buster (10). I’ve installed php-redis through debian repositories.

    Here is my diagnostics;

    Status: Disabled
    Client: 
    Drop-in: Invalid
    Redis Extension: 4.2.0
    Predis Client: 1.1.1
    PHP Version: 7.3.9-1~deb10u1
    Multisite: No
    WP_CACHE_KEY_SALT: "SALT_KEY"
    WP_REDIS_PASSWORD: "****************************************************************************************************************************************************************************************************************************************************************"
    Plugins: 
     - Akismet Anti-Spam v4.1 by Automattic (Inactive)
     - All-in-One WP Migration v6.73 by ServMask (Active)
     - Classic Editor v1.3 by WordPress Contributors (Active)
     - Hello Dolly v1.6 by Matt Mullenweg (Inactive)
     - LayerSlider WP v5.6.10 by Kreatura Media (Active)
     - Nginx Helper v2.1.0 by rtCamp (Active)
     - Redis Object Cache v1.5.0 by Till Krüss (Active)
     - WPBakery Visual Composer v4.12.1 by Michael M - WPBakery.com (Active)
     - Yoast SEO v9.2.1 by Team Yoast (Active)

    I get Object cache could not be enabled. when I try to enable the cache.

    I’ve check my redis server with redis-cli. It works perfectly. I’ve also MONITOR through redis-cli to catch if php is hitting the server but get nothing.

    I’ve also enabled debug and display errors to get a hint what’s going on. But ended up with no success.

    Edit: I’ve just located some errors on nginx log;

    2019/10/25 14:57:40 [error] 440#440: *1189 FastCGI sent in stderr: "PHP message: PHP Warning: copy(/srv/www/sites/www.example.com/public/wp-content/object-cache.php): failed to open stream: No such file or directory in /srv/www/sites/www.example.com/public/wp-admin/includes/class-wp-filesystem-direct.php on line 247" while reading response header from upstream, client: ::ffff:195.174.215.70, server: www.example.com, request: "GET /wp-admin/options-general.php?page=redis-cache&action=enable-cache&_wpnonce=401a3fdb8d HTTP/2.0", upstream: "fastcgi://unix:/run/php7.3-fpm-example_com.sock:", host: "www.example.com", referrer: "https://www.example.com/wp-admin/options-general.php?page=redis-cache"

    • This topic was modified 3 weeks, 3 days ago by antsomers. Reason: Add debug information
    • This topic was modified 3 weeks, 3 days ago by antsomers. Reason: Add error log
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Sounds like WordPress doesn’t have enough permissions to enable the object-cache.php. You could manually copy the file from the plugin folder.

    I’ve addressed the problem. WP Redis plugin doesn’t delete object-cache.php symlink after its deletion. Problem solved after deleting it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.