Support » Plugin: Gutenberg » nvariant Violation: Minified React error #130;

  • Resolved tradik

    (@tradik)


    
    Invariant Violation: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args[]=undefined&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings. 
        at Sg (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:142:327)
        at m (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:12:388)
        at ed (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:65:98)
        at If (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:82:141)
        at v (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:84:389)
        at https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:88:328
        at rd (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:91:10)
        at O (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:90:455)
        at yh (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:104:145)
        at lg (https://12.webside-dev.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:88)
    

    how to solve? all dev work is stopped after update.

    • This topic was modified 2 years, 1 month ago by t-p.
    • This topic was modified 2 years, 1 month ago by Marius L. J.. Reason: Added code tags for readablity

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Same error here after updating to 3.8.

    
    Invariant Violation: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args[]=undefined&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings. 
        at Sg (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:142:327)
        at m (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:12:388)
        at ed (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:65:98)
        at If (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:82:141)
        at v (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:84:389)
        at /wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:88:328
        at rd (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:91:10)
        at O (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:90:455)
        at yh (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:104:145)
        at lg (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:88)
    
    • This reply was modified 2 years, 1 month ago by Marius L. J.. Reason: Added code tags for readablity
    VP

    (@studio500)

    Same error for me too. Unable to create a new post.

    
    Invariant Violation: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args[]=undefined&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings. 
        at Sg (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:142:327)
        at m (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:12:388)
        at ed (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:65:98)
        at https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:87:294
        at rd (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:91:10)
        at O (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:90:455)
        at yh (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:104:145)
        at lg (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:88)
        at mg (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:386)
        at gc (https://www.bisfhouse.com/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:127:202)
    
    VP

    (@studio500)

    Same issue, even with all plugins disabled.
    I can still use the classic editor to edit existing posts but I am not able to create new posts or pages as the above error shows instead.

    I did post my full error code above but for some reason it has been held for moderation.

    • This reply was modified 2 years, 1 month ago by VP.
    VP

    (@studio500)

    I’ve posted this error on github for the team to see and suggest anyone else who has same error does so too.

    Github

    VP

    (@studio500)

    I think I may have found a solution that worked for me at least.

    Go to permalinks in settings, change your structure to something other than your default, then save.

    Then select your usual permalink, for example, postname and save.

    Return to your problem pages and check status.

    I hope this helps.

    Marc

    • This reply was modified 2 years, 1 month ago by VP.

    Here’s another report on GitHub issue for anyone who wants to follow it:

    https://github.com/WordPress/gutenberg/issues/9885

    Will Stocks

    (@willstockstech)

    I too am seeing this error. Post add new dropdown and selecting classic editor works fine, but Gutenberg throws the below error. I tried the above mentioned fix/troubleshooting, however that hasn’t resolved the issue for me.

    “Copy error” output:

    
    Invariant Violation: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args[]=undefined&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings. 
        at Sg (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:142:327)
        at m (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:12:388)
        at ed (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:65:98)
        at /wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:87:294
        at rd (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:91:10)
        at O (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:90:455)
        at yh (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:104:145)
        at lg (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:88)
        at mg (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:120:386)
        at gc (/wp-content/plugins/gutenberg/vendor/react-dom.min.82e21c65.js:127:202)
    
    • This reply was modified 2 years, 1 month ago by Marius L. J.. Reason: Added code tags for readability

    @willstockstech, can you try temporarily disabling all other plugins, switching to one of the default themes, and disabling any browser extensions you have installed? Then, test if you still see the error?

    If you don’t, you can identify which plugin/theme/extension is conflicting with Gutenberg by turning them back on one-by-one, until you get the error again.

    If you can identify the conflict, I can examine the code to see why they’re conflicting.

    Will Stocks

    (@willstockstech)

    @iandunn – I’ll have to spin up a dev site in that case.
    Browser extensions – None, so can’t be the issue there.
    Theme – Had been alright until 3.8 (and has no react code in theme either) but I can defo revert back to a stock theme just to double check.
    Plugins – I have seen some noise about Yoast causing issues in 3.8, which I do use. But again, I’ll see if I can get a local dev site setup and will revert everything to a “fresh” install.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘nvariant Violation: Minified React error #130;’ is closed to new replies.