Support » Plugin: WPSiteSync for Content » numerous PHP errors on setup

  • Resolved photocurio

    (@photocurio)


    I installed wpsitesynccontent, and entered my Target Host, user name and password on the settings page. After hitting Save Changes I got these errors:

    Notice: Undefined index: host in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/settings.php on line 527
    
    Notice: Undefined index: host in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/settings.php on line 536
    
    Deprecated: Function mcrypt_get_iv_size() is deprecated in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/auth.php on line 146
    
    Deprecated: Function mcrypt_create_iv() is deprecated in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/auth.php on line 147
    
    Deprecated: Function mcrypt_encrypt() is deprecated in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/auth.php on line 148
    
    Warning: Cannot modify header information - headers already sent by (output started at /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-content/plugins/wpsitesynccontent/classes/settings.php:527) in /Users/petermumfordaddminaccount/Documents/WP Engine/newsroom/wp-includes/pluggable.php on line 1216
Viewing 4 replies - 1 through 4 (of 4 total)
  • p.s. I should add that I get a whitescreen with these errors.

    • This reply was modified 1 year, 9 months ago by  photocurio.
    Plugin Author ServerPress

    (@serverpress)

    Hi Peter,

    Thanks for contacting us and letting us know about the error messages you’re seeing. And thanks for submitting a support request on our web site. We’ve sent you an updated copy to test and verify that the error messages no longer appear and we’ll be updating the version in the WordPress repository with these changes shortly.

    Please feel free to let us know if you have any further issues we can help you with.

    I’ve been told these are warnings, not errors. And although the whitescreen made me think it broke my site, niether the site nor the admin was actually broken. Just the page /wp-admin/options.php was broken.

    Anyway, the developers provided me with a fix, and testing shows no more php warnings, and no whitescreen. Nice! I assume this fix will be in the next release of the plugin.

    Plugin Author ServerPress

    (@serverpress)

    Hi Peter,

    Thanks for the clarification. And we’re glad to hear that the changes are working for you!

    Yes — these fixes, plus a few other changes, will be included in our next release. That will be coming soon.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘numerous PHP errors on setup’ is closed to new replies.